Pegasus Mail & Mercury

Welcome to the Community for Pegasus Mail and
The Mercury Mail Transport System, the Internet's longest-serving PC e-mail system!
Welcome to Pegasus Mail & Mercury Sign in | Join | Help
in
Home Blogs Forums Downloads Pegasus Mail Overview Mercury Overview Wiki

Problem mit Pop3 SSL bei Strato

Last post 03-20-2014, 8:41 by Laurel. 24 replies.
Page 1 of 2 (25 items)   1 2 Next >
Sort Posts: Previous Next
  •  12-13-2013, 11:31

    • alex96 is not online. Last active: 07-16-2014, 12:24 alex96
    • Not Ranked
    • Joined on 12-13-2013
    • Member
    • Points 75

    Problem mit Pop3 SSL bei Strato

    Hallo,

    Strato lässt seit 1.12. für neue Postfächer nur noch den Abruf über SSL V3 zu. 

    Wenn ich versuche Pegasus oder mercury folgendermaßen einzurichten:

     -pop3.strato.de

     -Port 995

     -direct SSL

    bekomme ich folgende Fehlermeldung: "Error -32 activating SSL session (locus 6014, type 4, code 0, 'Bad  server key agreement parameter signature')".

    Kann einer von euch erklären, wo hier das Problem liegt?

    Kann Pegasus eventuell das SSL V3 nicht?

    Gruß Alex.

    Filed under: ,
  •  12-13-2013, 13:36

    • FJR is not online. Last active: 2018-10-26, 12:54 FJR
    • Top 25 Contributor
    • Joined on 05-10-2007
    • Dortmund / Germany
    • Star
    • Points 7,430

    AW: Problem mit Pop3 SSL bei Strato

    Hallo Alex,

    > Kann Pegasus eventuell das SSL V3 nicht?

    Die aktuelle version kann das nicht.

    Die nächste Version, die David dieser Tage heraus bringen wird, arbeitet mit OpenSSL und wird dann auch SSL V3 können.

    vg    Olaf

     

  •  12-13-2013, 14:14

    • alex96 is not online. Last active: 07-16-2014, 12:24 alex96
    • Not Ranked
    • Joined on 12-13-2013
    • Member
    • Points 75

    Re: AW: Problem mit Pop3 SSL bei Strato

    Hallo Olaf,

    vielen Dank für die Info!

    Gruß Alex

  •  12-29-2013, 10:39

    • alex96 is not online. Last active: 07-16-2014, 12:24 alex96
    • Not Ranked
    • Joined on 12-13-2013
    • Member
    • Points 75

    Re: AW: Problem mit Pop3 SSL bei Strato

    Hat jemand im Forum nähere Erkenntnisse, wann die neue Version mit openSSL kommen soll?
  •  12-29-2013, 13:01

    • idw is not online. Last active: Wed, Nov 14 2018, 16:18 idw
    • Top 10 Contributor
    • Joined on 03-25-2007
    • Germany
    • SuperStar
    • Points 45,745
    • BetaTeam

    Re: AW: Problem mit Pop3 SSL bei Strato

    alex96:
    Hat jemand im Forum nähere Erkenntnisse, wann die neue Version mit openSSL kommen soll?

    Nein, das ist - wie immer - leider nicht vorhersagbar.


    Michael

    --
    PGP Key ID (RSA 2048): 0xC45D831B
    PGP Plugin for Pegasus Mail: <http://www.pmpgp.de/pmpgp/>
    S/MIME Certificate Fingerprint: 26 5c a3 60 02 c6 e3 8a 75 70 d5 6a 67 ff d3 8d b0 b5 5e 5b
  •  01-30-2014, 12:36

    • paul66 is not online. Last active: 01-30-2014, 16:27 paul66
    • Not Ranked
    • Joined on 01-30-2014
    • Member
    • Points 40

    Re: AW: Problem mit Pop3 SSL bei Strato

    Hallo,

    ich habe gerade das selbe Problem wie alex96, aber merkwürdigerweise steht in der Hilfe meiner Version 4.51 zum Thema SSL Verschlüsselung folgendes:

    "Bevor Sie die SSL-Unterstützung in Pegasus Mail aktivieren, sollten Sie Ihren System-Administrator fragen, ob die verwendeten Server verschlüsselte Verbindungen mit SSL Version 3 überhaupt unterstützen."

     Das bedeutet ja wohl, dass Pegasus sehr wohl SSL Version 3 kann. Oder sind die Angaben in der Hilfe falsch? Kann das jemand klären?

    Gruß

     Paul

  •  01-30-2014, 13:21

    • FJR is not online. Last active: 2018-10-26, 12:54 FJR
    • Top 25 Contributor
    • Joined on 05-10-2007
    • Dortmund / Germany
    • Star
    • Points 7,430

    Re: Problem mit Pop3 SSL bei Strato

    Hallo Paul,

    vielleicht sollte man mal ein paar Begriffe klarstellen. Zum einen ist es so, dass der ganze Verschlüsselungskram in einer Norm zusammengefasst wurde - TLS (Transport Layer Security). Secure Sockets Layer (SSL) ist allerdings die bisher bekanntere Bezeichnung dafür. Dabei entsprciht TLS V1.0 ungefähr SSL V3.0 oder SSL V3.1. TLS 1.0 kann auch PM451 schon ... das ist richtig.

    Einige Anbieter (wie Strato) zwingen ihre Kunden nicht nur, überhaupt IMAP, POP und SMTP auf SSL/TLS umzustellen (was ja durchaus sinnvoll ist), sondern sie schalten gleichzeitig die Unterstützung für TLS 1.0 ab und fordern minimal TLS 1.1. Das kann selbst PM463 nicht, weswegen für solche Fälle eben dringend ein Update (via OpenSLL) nötig ist - die kommend PM V4.70.

     vg    Olaf

     

  •  01-30-2014, 16:27

    • paul66 is not online. Last active: 01-30-2014, 16:27 paul66
    • Not Ranked
    • Joined on 01-30-2014
    • Member
    • Points 40

    Re: Problem mit Pop3 SSL bei Strato

    Hallo Olaf,

    Danke für die Klarstellung. Hoffentlich müssen wir nicht zu lange warten.

    Gruß, Paul

  •  01-30-2014, 19:09

    AW: Re: Problem mit Pop3 SSL bei Strato

    Bis die neue Version rauskommt, kann man sich mit stunnel behelfen, funktioniert prima.

    Zur Konfiguration mit Pegasus siehe http://community.pmail.com/forums/thread/39961.aspx

    Und stunnel gibts hier: https://www.stunnel.org/index.html

    HTH

    Martin


    Martin Schnabel
  •  03-07-2014, 8:25

    Re: AW: Re: Problem mit Pop3 SSL nun auch bei Telekom

    es scheint, als ob der Countdown nun auch bei der TELEKOM tickt. Seit gestern Mittag klappt es mit SSL via 4.63 nicht mehr. Ab Ende Oktober 2013 arbeiteten die umgestellten Installationen fehlerfrei!

    stunnel ist (für mich) nicht verwaltbar (mehrere Systeme mit z.T. kultigen Betriebssystemständen),  daher die dringende Bitte um Info, ob die avisierte 4.70 noch vor Ende März erscheinen wird. Bis dato habe ich wieder auf unverschlüsseltes mailing umgestellt, das ist aber eine Sackgasse, wie wir alle wissen. 

     

    Hat D. Harris sich schon geäußert?

     

    mfg Peter

     

     

     

    Filed under: , , ,
  •  03-07-2014, 8:42

    • ecz is not online. Last active: 13-10-2018, 11:22 ecz
    • Top 75 Contributor
    • Joined on 03-25-2007
    • Austria
    • Member
    • Points 1,380
    • BetaTeam Moderator

    AW: Re: AW: Re: Problem mit Pop3 SSL nun auch bei Telekom

    das release von 4.70 steht unmittelbar bevor ...
  •  03-07-2014, 17:09

    • Morkhero is not online. Last active: 04-03-2016, 19:16 Morkhero
    • Not Ranked
    • Joined on 05-05-2012
    • Member
    • Points 70

    Re: AW: Re: AW: Re: Problem mit Pop3 SSL nun auch bei Telekom

    Vielen dank für die Info. Da bin ich beruhigt. Ich dachte schon ich muss mich von Pegasus trennen und das wo ich mit gar nichts anderem klar komme hehe.
  •  03-07-2014, 19:20

    • HarryM is not online. Last active: 03-12-2014, 19:01 HarryM
    • Not Ranked
    • Joined on 03-07-2014
    • Germany
    • Member
    • Points 65

    Re: Problem mit Pop3 SSL nun auch bei Telekom

    P.Nieratschker:

    es scheint, als ob der Countdown nun auch bei der TELEKOM tickt. Seit gestern Mittag klappt es mit SSL via 4.63 nicht mehr. Ab Ende Oktober 2013 arbeiteten die umgestellten Installationen fehlerfrei!

    Kann ich auch bestätigen: Seit ca. 05.03.2014 geht SSL auf securepop.t-online.de mit Pegasus Mail 4.63 nicht mehr.

    (Obwohl lt. "sslscan --no-failed securepop.t-online.de:995 | less -R" einige Varianten von SSLv3 gehen.)

     

    Freenet funktioniert noch, der lt. "sslscan --no-failed mx.freenet.de:995 | less -R" zwar kein SSLv2 mehr ermöglicht, jedoch ein paar Varianten mehr von SSLv3, darunter einige mit 56 bit.
    Ich vermute, diese beherrscht Pegasus Mail 4.63 noch, und daher geht's. (Weil es hier wohl irgendwo hieß, PM könne angeblich nur SSLv2.)

     

    Leider können aktuelle Versionen von sslscan ja noch nicht explizit auf TLSv1.1 und TLSv1.2 testen, sondern nur TLSv1.

    "openssl s_client -connect securepop.t-online.de:995 -no_tls1" (ggf. noch " -no_ssl3") zeigt ja auch nicht so ganz präzise an, was man über die unterstützten Features wissen will.
    Vielleicht kennt da jemand bessere Prüfmethoden?

     

    Gruß, Harald

  •  03-08-2014, 3:18

    • David Harris is not online. Last active: 11-02-2018, 1:14 David Harris
    • Top 25 Contributor
    • Joined on 01-31-2007
    • New Zealand
    • Star
    • Points 9,950
    • SystemAdministrator

    Re: AW: Re: Problem mit Pop3 SSL nun auch bei Telekom

    My German's pretty rusty, but I get the gist of this posting - problems connecting because of the SSL module in Pegasus Mail.

    Pegasus Mail v4.70 is in the release process as I write this - I'm putting the final touches on the release archives for both English and German installers. V4.70 now uses OpenSSL for its SSL connections, and should work with all compliant SSL services. We know for a fact that the new code fixes problems for Verizon users in the USA, and initial reports from my testers are that the German providers who have similar problems now also work correctly with v4.70.

    I will make a release announcement here and on the http://www.pmail.com website when the release is actually publicly available - almost certainly sometime this weekend.

    Cheers!

    -- David --

  •  03-08-2014, 3:57

    • jbanks is not online. Last active: 11-11-2018, 18:50 jbanks
    • Top 50 Contributor
    • Joined on 06-09-2007
    • Prince Edward Island, Canada
    • Member
    • Points 1,225

    Re: AW: Re: Problem mit Pop3 SSL nun auch bei Telekom

    Woo hoo- always get excited when I hear about new releases.  Can't wait!
Page 1 of 2 (25 items)   1 2 Next >
View as RSS news feed in XML

Contact | Advertise | Host provider: PraktIT | Terms of Use | Privacy Statement
Copyright © 2007-2011 David Harris / Peter Strömblad. | Pegasus Mail Home Page