Pegasus Mail & Mercury

Welcome to the Community for Pegasus Mail and
The Mercury Mail Transport System, the Internet's longest-serving PC e-mail system!
Welcome to Pegasus Mail & Mercury Sign in | Join | Help
in
Home Blogs Forums Downloads Pegasus Mail Overview Mercury Overview Wiki

IMAP won't copy to local New Mail folder

Last post 12-06-2018, 8:51 by FJR. 4 replies.
Sort Posts: Previous Next
  •  11-02-2018, 23:02

    • jschaper is not online. Last active: 12-02-2018, 21:23 jschaper
    • Not Ranked
    • Joined on 01-18-2016
    • Member
    • Points 85

    IMAP won't copy to local New Mail folder

    A few weeks ago Pegasus - which I have been using for almost 18 years now - stopped copying messages from my IMAP 'New or unread mail' box at my ISP, to my local New Mail folder. This happened on both (Windows 7) machines I have Pegasus installed on. 

    The IMAP connection in itself is OK; I even CAN copy from the remote Spam, Trash or Archive folders to local New Mail folder.

    This problem used to appear before from time to time, since a few years; but closing and re-starting Pegasus would normally solve it. Not so now, and this effectively renders Pegasus unusable for me. I installed Thunderbird, but don't like it, and find it sluggish.

    So, I would love to find a solution to be able to keep using Pegasus.

    Any suggestions? Thanks a lot in advance!

    -- jschaper

  •  11-07-2018, 13:50

    • PaulW is not online. Last active: 08 Dec 2018, 10:43 PaulW
    • Top 10 Contributor
    • Joined on 05-08-2007
    • UK
    • SuperStar
    • Points 18,225

    Re: IMAP won't copy to local New Mail folder

    I've not found any problem myself.

    How are you copying the messages - manually for each one or by some filtering rule?

  •  11-10-2018, 18:52

    • jschaper is not online. Last active: 12-02-2018, 21:23 jschaper
    • Not Ranked
    • Joined on 01-18-2016
    • Member
    • Points 85

    Re: IMAP won't copy to local New Mail folder

    Thanks for your reply, Paul. But I don't think it a Peagsus bug - it must have something to do with my use of Pegasus - the problem is, I have not the faintest idea what can be wrong. 

    I can still connect to my IMAP account, and when I click on its 'New or unread mail (INBOX)' folder, Pegasus opens a window that shows alle messages in it, including the most recent ones. The problem is I can no longer copy new messages (or old ones - the whole idea of IMAP is that you leave alle messages on your provider's server and don't delete them from there, or at least not very often) to my LOCAL New mail folder. The Pegasus status bar says it is downloading the message(s), but then the computer gives a 'general fault' sound, and the messages fail to appear locally.

    And opening messages directly from the IMAP inbox is possible - but the openend message's window in Pegasus then says: 'This message contains binary or non-textual data that cannot be previewed within Pegasus Mail.' Anyway, I don't want to open messages directly out of the IMAP inbox, but dnowload them to my local inbox first - for archiving purposes, too.

    BR, 

    ~jp schaper 

  •  11-12-2018, 19:02

    • aderoy is not online. Last active: 12-10-2018, 20:36 aderoy
    • Top 50 Contributor
    • Joined on 05-09-2007
    • Participant
    • Points 2,495

    Re: IMAP won't copy to local New Mail folder

    Could this be due to using 'Preview Mode' over List view mode?

    I use the older list view , double click on the New folder which then opens in a new window. Still in list mode no preview of message. Then  use Control left click on multiple messages and then (C)opy or (M)ove  a new popup dialog will display asking where to place the message(s).

     Of course I also have filters that can be manually applied to selected messages.

    Using 4 IMAP accounts and local mailstore as backup and/or to trim the IMAP mailstore due to file size limits on mail accounts. 

     

  •  12-06-2018, 8:51

    • FJR is not online. Last active: 2018-12-07, 14:55 FJR
    • Top 25 Contributor
    • Joined on 05-10-2007
    • Dortmund / Germany
    • Star
    • Points 7,450

    Re: IMAP won't copy to local New Mail folder

    The cachefiles for IMAP-Inbox are corrupted. May be - as I understand your use of IMAP - because there are thousands of Mails in the Inbox or because Pegasus sometimes crashed or was stopped hard while writing cashfiles.

    Right-klick the folder > Information on folder (translated - not shure about nomination of menue entry in english) and delete both cashfiles. To enshure cashfiles are deleted restart Pegasus. Check if Pegasus realy has deleted the cashfiles. I not (have the old size) come back to me.

    If there are thousands of mails in, create a folder structure i.e. "Archives" and one folder per year. Move mails from Inbox to that folders. Inbox is your "working folder" and I think it should have as less mails as possible.

    bye    Olaf

View as RSS news feed in XML

Contact | Advertise | Host provider: PraktIT | Terms of Use | Privacy Statement
Copyright © 2007-2011 David Harris / Peter Strömblad. | Pegasus Mail Home Page