Pegasus Mail & Mercury

Welcome to the Community for Pegasus Mail and
The Mercury Mail Transport System, the Internet's longest-serving PC e-mail system!
Welcome to Pegasus Mail & Mercury Sign in | Join | Help
in
Home Blogs Forums Downloads Pegasus Mail Overview Mercury Overview Wiki

Disabling the Unknown Publisher security warning dialog

Last post 01-10-2007, 0:00 by Pmail.Com. 0 replies.
Sort Posts: Previous Next
  •  01-10-2007, 0:00

    Disabling the Unknown Publisher security warning dialog

    Q: After installing Internet Explorer 7, our users are seeing an Unknown Publisher security warning dialog every time they run the networked copy of Pegasus Mail over our LAN. How do I stop this from happening?

     

    A: To disable this security warning dialog, open the Internet Options control panel applet, then click on the Security tab, then click on the Local Intranet icon, then click on the Sites... button. Within the dialog that appears, disable the "automatically detect intranet network" checkbox option and enable the "include all network paths (UNCs)" checkbox option. Then click OK to close each dialog.

    This process should force Windows to treat all UNC paths as Intranet paths, which is usually the case. However, this does open you up to security threats from Internet sites if you are able to access them via a UNC path. e.g.

    \\malicious.site.com\share\badfile.exe

    Another method to get around this problem, but without requiring all UNC paths to be treated as part of the Local Intranet, is to disable the "automatically detect intranet network" checkbox, as explained above, but then also disable the "include all network paths (UNCs)" checkbox option, then click the Advanced... button and add the computer name and full DNS host name of the networked resource (e.g. server1.mydomain.com) to the Local Intranet zone list, then click OK to close each of the dialogs. You can also add your whole domain by using a wildcard. e.g. *.mydomain.com

    This security warning can also appear on PCs running IE6 if the "include all network paths (UNCs)" checkbox option is disabled and the network host or domain has not been added to the Local Intranet zone list. In such a case, you'll also find it impossible to open an .MDB file within MS Access from over a network share.

View as RSS news feed in XML

Contact | Advertise | Host provider: PraktIT | Terms of Use | Privacy Statement
Copyright © 2007-2011 David Harris / Peter Strömblad. | Pegasus Mail Home Page