Pegasus Mail & Mercury

Welcome to the Community for Pegasus Mail and
The Mercury Mail Transport System, the Internet's longest-serving PC e-mail system!
Welcome to Pegasus Mail & Mercury Sign in | Join | Help
Home Blogs Forums Downloads Pegasus Mail Overview Mercury Overview Wiki

Variable Signature Not Fully Functional

  •  05-24-2013, 3:24

    • enxss is not online. Last active: 07-05-2016, 4:41 enxss
    • Not Ranked
    • Joined on 05-23-2013
    • Member
    • Points 95

    Variable Signature Not Fully Functional

    I have been a long time user of Pegasus and recently installed v 4.6.3 on a machine running a 64 bit version of Windows 7. Unfortunately the Variable Signature feature is not fully functional. I say not fully functional because when the options:

    Tools/Options/Outgoing Mail/Signatures/Add this variant of default signature upon message creation, Variant: Internet address, formatted content

    is selected, the program fails to insert the variable signature upon creation of a new message. However, if the additional option of:

    /Add this variant of default signature upon message creation

    is left unchecked, Pegasus processes the message and properly inserts the variable signature when it is sent to the SMTP server. In addition, if the options:

    /Add this variant of default signature upon message creation, Variant: Internet address, plain content

    are selected, Pegasus properly places the Variable Signature in the body of the message when it is first created, as would be expected.

    From this behavior it would appear that the rquotes.r file has been properly formatted and that rquotes.pms has been properly compiled by rescom.exe.

    text x
    {
    "Thought for the day:\n",
    " If we knew what it was we were doing, it would not be\n",
    " called research, would it?\n",
    " -- Albert Einstein (1879-1955)\n",
    };

    I believe that it would further indicate that rquotes.pms currently resides in the correct folder: e.g. Z:\Pmail\Mail, on my machine.

    WINPMAIL.EXE directory: C:\PMAIL\Programs
    Home mailbox location: Z:\PMAIL\MAIL
    New mailbox location: C:\PMAIL\MAIL\Admin
    TMP environment variable: C:\Users\Enxss\AppData\Local\Temp
    TEMP environment variable: C:\Users\Enxss\AppData\Local\Temp
     

      Also, I believe that the signature file itself is properly formatted with the ~! as required.

    Enxss

    ~!

    One last observation, although Pegasus will not place the formatted variable signature into the body of a new message, as described above, it will properly place it into the body of a new message that is a reply to a received message.

    So given the above outline, it appears that the issue is confined to placing the variable signature into the body of a new email (not a reply) solely when the option:

    /Add this variant of default signature upon message creation

    is selected in conjunction with:

    Variant: Internet address, formatted content

    I have tried several variations to the formatting of the signature file, including removing it and reconstructing it as both formatted and plain text, to no avail.

    As I mentioned previously, I have been a long time user of Pegasus. And until the recent change to Win 7, 64 bit I had been using Pegasus on a machine running Win XP, 32 bit. No such issue as is described was every encountered with XP. Am I overlooking something? Is there, perhaps, a conflict with the 64 bit version of Win 7 that is causing the partial disabling of the feature? At this point I am stumped.

    BTW, I did review several posts discussing similar issues before publishing this one, including the following:

    http://community.pmail.com/forums/thread/25178.aspx

    In it, essentially the same error was resolved on a Win 7, 64 bit machine by relocating the rquotes.pms file to the user’s personal mail folder, e.g. C:\Pmail\Mail\<My Username>\rquotes.pms. I tried it on machine with no such luck.

    I have always enjoyed this feature of Pegasus Mail and would hate to see it lost simply because of a transition to a 64 bit system. Any thoughts as to how I may be able to rectify this issue would be greatly appreciated.

    Filed under: , ,
View Complete Thread

Contact | Advertise | Host provider: PraktIT | Terms of Use | Privacy Statement
Copyright © 2007-2011 David Harris / Peter Strömblad. | Pegasus Mail Home Page