Pegasus Mail & Mercury

Welcome to the Community for Pegasus Mail and
The Mercury Mail Transport System, the Internet's longest-serving PC e-mail system!
Welcome to Pegasus Mail & Mercury Sign in | Join | Help
Home Blogs Forums Downloads Pegasus Mail Overview Mercury Overview Wiki

V4.70 woes...

  •  12-04-2014, 17:44

    V4.70 woes...

    Well, in the last few days I've finally started using PM V4.70 in earnest on a recently-built Win7 (32-bit Professional) machine after migrating all my mail folders and PM config stuff off the WinXP machine on which I'd used an earlier version (V4.21c I think) reliably for many (approaching ten) years.  Unfortunately I'm finding that V4.70 on the Win7 machine is decidely unreliable, in the following ways:

    Firstly, PM sometimes crashes when I try to do standard things such as reply to or send an email; Windows reports the crash and the following is the report that was generated by Windows a few minutes ago at the time of the most recent crash:

     Problem signature:
      Problem Event Name:    APPCRASH
      Application Name:    WINPM-32.EXE
      Application Version:    4.7.0.1
      Application Timestamp:    530f0f0f
      Fault Module Name:    WINPM-32.EXE
      Fault Module Version:    4.7.0.1
      Fault Module Timestamp:    530f0f0f
      Exception Code:    c0000005
      Exception Offset:    003d9a49
      OS Version:    6.1.7601.2.1.0.256.48
      Locale ID:    2057
      Additional Information 1:    0a9e
      Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
      Additional Information 3:    0a9e
      Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

    Read our privacy statement online:
      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
      C:\Windows\system32\en-US\erofflps.txt
     

    I haven't observed any clear pattern for the cause of these crashes - they seem to happen only sometimes when I try to do something absolutely standard like sending a reply to a received email.  As far as I've been able to tell, there's nothing in the content of a received email that I'm trying to open or to reply to that might be causing the crash - I can restart PM after the crash and then successfully achieve what I was trying to do before the crash happened.  It's extremely annoying, not least because my previous experiences of PM over almost 20 years have been almost entirely positive.

    The second issue I'm having is associated with the 'Change User' function that I'm invoking via a button in a custom toolbar - see my postings of a few weeks ago this.  When I invoke the 'Change User' function using the toolbar button and enter a different username into the dialogue box, most of the time PM changes to the desired user successfully.  However, occasionally when I enter the username and then hit the 'Enter' key PM disappears and shuts down completely, with no dialogue or error messages whatsoever.  When I then restart PM from the desktop shortcut it comes back up minimised, in the user account to which I was trying to change.

    I realise and accept that the 'Change User' function isn't now the preferred way of accessing multiple mail user accounts, but it's a function that I've used happily and entirely reliably over many years so I'd like to continue using it as long as it behaves reliably, which sadly it's currently not.

    Does anyone have any thoughts about the causes of the issues I'm having with V4.70, most especially the first one described above?  It really is annoying and frustrating to have a program as good as PM misbehave and be unreliable in this way...

    Thanks in advance,

    -- 

    Martin

    Filed under: ,
View Complete Thread

Contact | Advertise | Host provider: PraktIT | Terms of Use | Privacy Statement
Copyright © 2007-2011 David Harris / Peter Strömblad. | Pegasus Mail Home Page