Pegasus Mail & Mercury

Welcome to the Community for Pegasus Mail and
The Mercury Mail Transport System, the Internet's longest-serving PC e-mail system!
Welcome to Pegasus Mail & Mercury Sign in | Join | Help
in
Home Blogs Forums Downloads Pegasus Mail Overview Mercury Overview Wiki

USB Thumb Drive; Consistent Failure

Last post 09-06-2011, 22:57 by A01. 3 replies.
Sort Posts: Previous Next
  •  09-06-2011, 16:43

    • A01 is not online. Last active: 2012-01-07, 17:03 A01
    • Top 50 Contributor
    • Joined on 08-24-2008
    • Participant
    • Points 2,110

    USB Thumb Drive; Consistent Failure

     

    ======= BOGUS  BOGUS BOGUS =========== 

    ======= IGNORE ! IGNORE ! IGNORE ! ========

    I'm leaving this for archive and historical purposes, in case it happens to someone else.

    This is *NOT* a bug in Pegasus.  There is something wrong (big wrong) with my machine at home.  I'm composing this from a regular machine at a shop away from home.  Same thumb drive, etc.  (By the way, David, et.al., 4.62 works like a champ here and now and today)

    It's an error somewhere else. For now, I will leave the speculation open. Likely candidates are...

    • A virus acquired from the internet.
    • A problem with windows (acquired from MicroSoft) 
    • A wrong file setting with Pegasus somewhere on my machine 

    Just in case anyone else ever has a similar problem, here are the symptoms as best I was able to observe and document them...

     

     

    ===================================================================== 

    Original "Bug"  report (i.e., the false report)  follows below just for history

    ===================================================================== 

     

    I have used Pegasus on a thumb drive with excellent results for the past two months.

    1. Plug it in (just about anywhere)
    2. Run it
    3. Get my day's messages
    4. Exit
    5. Remove thumb drive
    6. Be on my way
    7. Go home
    8. Plug in thumb drive
    9. Run it
    10. Read, write, and respond
    11. Exit
    12. Turn off computer
    13. Go to sleep
    14. Wake up
    15. Loop to step #1


    Starting this past weekend, I began experiencing strange, inconsistent, confusing errors, always centered on step #9 in the list above; i.e., running Pegasus from the thumb drive on my home computer.

    In each attempt to invoke an instance of Pegasus, the program will not load.

    The same thing happened a day or two ago.  I re-installed Pegasus and the program loaded and executed properly several times.

    Today, the (errant) behavior resumed.  I re-installed again, but this time, the behavior is persistent. I am unable to load Pegasus at all. I will list the errors that I can reproduce, along with observed error messages, below.

    I looked on this website, and saw that the latest version has been released in the past day or two. I downloaded it, ran the installation and I experience the identical behavior.

    I tried unplugging the USB thumb drive and inserting it into another USB port. Same behavior.

    I tried opening an MS-DOS command window (the CMD thing) and executed the command "winpm-32 -roam -A" (no quotes); same results again.

    And now for the strangest of the strange; after I click "OK" or "Don't send", those windows disappear, and then, a new window pops up, the exact same sort of window which appears shortly after plugging the USB thumb drive into a USB port on the computer; i.e., the error essentially returns the procedure above to step #2

    Current brain state:  "duh" (no quotes).


    === ERROR MESSAGES ===

    (Not necessarily in order; the sequence is confusing to say the least)


    ( Window Title: "Application Error"  A Red_Circle_X type of box)

    "...The application failed to initial properly (0x00000006). Click on OK to terminate the app..."


    (Window Title: "winpm-32.exe" send or don't send error report)

    "...winpm-32.exe has encountered a problem and needs to close. We are sorry..."


  •  09-06-2011, 16:54

    • A01 is not online. Last active: 2012-01-07, 17:03 A01
    • Top 50 Contributor
    • Joined on 08-24-2008
    • Participant
    • Points 2,110

    Re: USB Thumb Drive; Consistent Failure

    Just found another error message...


    (Window Title: "D:\X\P\PM\PMAIL\HOME\Programs\winpm-32.exe  Red_Circle_X box )

    "...Windows cannot find 'D:\X\P\PM\PMAIL\HOME\Programs\winpm-32.exe'.  Make sure that you typed the name correctly, and then try again. To search for a file, click the start button and then click Search...."   [OK button]


    Shortly after that window pops up, another window pops up, and we return to step #2 of the original process again

  •  09-06-2011, 18:33

    • idw is online. Last active: Wed, Oct 23 2019, 18:11 idw
    • Top 10 Contributor
    • Joined on 03-25-2007
    • Germany
    • SuperStar
    • Points 47,415
    • BetaTeam

    Re: USB Thumb Drive; Consistent Failure

    Try installing my MiniDump extension into a subdirectory of Pegasus Mail's program directory (i.e. onto the USB drive, it should get suggested automatically by the installer provided you ever launched Pegasus Mail successfully from the respective drive on the respective machine): It might help reporting the underlying issue (please read MiniDump's ReadMe file for details) although I'm not sure it'll work properly in such an environment, but IMO it's the only way to figure out what might be going on.

    Aside from this I don't understand what you mean by return to step #2: You're talking about using the USB stick in different locations, so why would execution failure get you back to another location to start over (in short: #2 happens in a different location/machine than #9)? Sounds rather confusing to me ...


    Michael

    --
    PGP Key ID (RSA 2048): 0xC45D831B
    PGP Plugin for Pegasus Mail: <http://www.pmpgp.de/pmpgp/>
    S/MIME Certificate Fingerprint: 94 c6 b4 71 0c 62 30 88 a5 b2 77 01 74 2b 86 66 3b 7e 65 7c
  •  09-06-2011, 22:57

    • A01 is not online. Last active: 2012-01-07, 17:03 A01
    • Top 50 Contributor
    • Joined on 08-24-2008
    • Participant
    • Points 2,110

    Re: USB Thumb Drive; Consistent Failure

    First off, cancel all interest in this; it's not a bug.  It's most probably a virus in action. (I just edited the original post to reflect the bogus nature of my false report.)  No clue why it would attack Pegasus and not, hmm, OpenOffice.Org or whatever other freeware apps I'm running off the stick. But for whatever reasons, Pegasus is the victim. Duh.

    Secondly, sorry for any confusion. Step #2 in the list is what happens after the USB stick is plugged into the port; i.e., the little window opens and asks what you want to do.

    Now, to hunt the virus.

    Hmmm, any clues on that and I'll be grateful.

    It so happens that I've paid for 3 copies of Norton 360, and we're only using 1 of them. I wonder if it would be worth it, or if that would only exacerbate my problems.

     Whatever, whatever, thanks for the response. As you can imagine, I'm highly annoyed by this. I'm trying to figure out what on earth could have happened. I highly suspect some sort of hardware (possibly firmware in the stick) error in this.

    Whatever, thanks for your input.

View as RSS news feed in XML

Contact | Advertise | Host provider: PraktIT | Terms of Use | Privacy Statement
Copyright © 2007-2011 David Harris / Peter Strömblad. | Pegasus Mail Home Page