Pegasus Mail & Mercury

Welcome to the Community for Pegasus Mail and
The Mercury Mail Transport System, the Internet's longest-serving PC e-mail system!
Welcome to Pegasus Mail & Mercury Sign in | Join | Help
in
Home Blogs Forums Downloads Pegasus Mail Overview Mercury Overview Wiki

Problems doing POP with SSL ? Check anti-malware

Last post 01-08-2017, 18:00 by Sheepdog. 0 replies.
Sort Posts: Previous Next
  •  01-08-2017, 18:00

    • Sheepdog is not online. Last active: 05-08-2017, 14:43 Sheepdog
    • Not Ranked
    • Joined on 11-17-2014
    • Member
    • Points 125

    Problems doing POP with SSL ? Check anti-malware

    8 Jan 17 ARGH!! Years of struggle... and it may simply have been an anti-malware issue. To use SSL/ port 995 POP with Pegasus and mail.yahoo.com (and other) with Norton Internet Security, create Firewall exception, and be sure to move to top of "rules" list, ABOVE the rules that lock down everything not unlocked by "Higher" rules. "Years" because Norton, if that's what it was, only blocked the connection SOMETIMES. Eset's WONDERFUL security package dealt with the needs of my POP without these hassles. https://www.eset.com/us/search-brand/eis

    (First, turn your anti-malware off, try a POP access. Works? Didn't before? Maybe anti-malware!

    Turn it back on!! NOW!

    Second.... using SSL? Be advised that the SSL code in Pegasus was overhauled early in 2016. The problems below went back to before that, but you should probably update yourself. The Help/ About pop-up may say "v 4.7" in the icon, upper right. LOOK AT THE "fine print", lower left. I think it was at 4.71 that the new SSL code was introduced. At 8 Jan 17, 4.72 was the "current" version.. and it still said "4.7" in the icon, upper right. (Not complaining! All of the 4.7xxx variants ARE, 4.7 versions... just be aware, that for the SSL upgrade, you need go beyond 4.70... and don't assume that "4.7" is telling you WHICH 4.7xxx variant you have!)

     

    For Norton...

    Go to Settings/ Firewall

    Traffic Rules Tab...

     Add.

     Now... you CAN set up a rule that says "let anyone do anything". Resist the temptation to provide "generous" permissions when not sure what's needed.

     What I used, which SEEMS to help... still early days, and we know how fragile email is, anyway...

    Add an "ALLOW" rule. Next page

    Allow connections TO **and** FROM other computers. Next page 

    (Specify WHICH computer: ) Allow only.. listed below. (add) Individually: pop.mail.yahoo.co.uk was the one I needed. Next page 

    (Protocol) I'd like to try just TCP. For the moment, I broke my "narrow permissions" rule and allowed TCP and UDP. And allow on 995. I also added 110, probably unnecessarily. Next page 

    I didn't ask for Security Log history entries. You mt want to, but probably not "needed". I turned OFF "Apply rule for NAT traversal traffic. Next page 

    (What to call rule)... anything you like! I used "Allow pop.yahoo.co.uk 995 access". Next Page

    "Finish"... but you AREN'T FINISHED!!!... you must move your rule up the list, above the "block (almost everything)" rules which are there already, to establish default behavior.

    Apply. Close. And your "can't fetch email" woes should be over!!! (^_^)

    Contact details at http://sheepdogsoftware.co.uk... interested to learn if this helps anyone, or if there are errors. I don't monitor this forum closely, as much as I love Pegasus... have used it for MANY years.

     

    ===

    P.S. : Sad to say, above does not seem to be "100%" solution. Still, even post-excepetion-rule-creation, getting times when access denied... but... less often? Maybe it's the way the wind is blowing? Or wishful thinking. It DOES, in limited tests, seem that turning off my Norton to download mail MAY be helping. Only a "clue", maybe, NOT an answer! (of course, Sigh.)

     

View as RSS news feed in XML

Contact | Advertise | Host provider: PraktIT | Terms of Use | Privacy Statement
Copyright © 2007-2011 David Harris / Peter Strömblad. | Pegasus Mail Home Page