Pegasus Mail & Mercury

Welcome to the Community for Pegasus Mail and
The Mercury Mail Transport System, the Internet's longest-serving PC e-mail system!
Welcome to Pegasus Mail & Mercury Sign in | Join | Help
in
Home Blogs Forums Downloads Pegasus Mail Overview Mercury Overview Wiki

Once more: Mercury as a Service under MS Server 2016

Last post 09-06-2017, 15:57 by Joerg. 0 replies.
Sort Posts: Previous Next
  •  09-06-2017, 15:57

    • Joerg is not online. Last active: 09-11-2017, 16:37 Joerg
    • Top 25 Contributor
    • Joined on 03-25-2008
    • Germany
    • Contributor
    • Points 4,915

    Once more: Mercury as a Service under MS Server 2016

    Hi Guys,

    Are there any news regarding the setup of Mercury 4.8 as a service under MS Server 2016? Has anybody experiences on collaboration of Mercury and Server2016? We finally intend to retire our old MS Server 2003 where Mercury was installed by a third party tool as a Service many years ago. Don't remember what it was. But it worked without problems and we could always access the Mercury GUI via RDP connection with option [-admin] to the session "0" of the server where the GUI appears.

    Now I'm working on a sequence how to move different things from one server to the other, including Mercury. The plan is to make a new dump setup of Mercury 4.8 into similar folder structure at the new server, followed by a copy of the complete Mercury folder from the old server to the Mercury folder on the new server. Then I have to update the pmgate.sys for Pmail (because the new server will get a new IP). Finally I have to ensure, that Mercury starts automatically each time the server restarts.

    I've read also the old threads 46288 and 10266 which dealt with this topic. But they are very old and that's why I'm interested in recent experiences in this regard and most practical ways users has solved it. Maybe a solution is using the MS PowerShell command "new-service" to create a service and "sc" for start options.

    Greetings

    Joerg

    BTW: Checking the old Mercury Service on our Server 2003 turns out that Mercury is always started with commandline option [-sw]. Unfortunately I cannot find a description of possible commandline options for Mercury, neither in the pdf manual nor in the ordinary program help. Where could I find them?


View as RSS news feed in XML

Contact | Advertise | Host provider: PraktIT | Terms of Use | Privacy Statement
Copyright © 2007-2011 David Harris / Peter Strömblad. | Pegasus Mail Home Page