Pegasus Mail & Mercury

Welcome to the Community for Pegasus Mail and
The Mercury Mail Transport System, the Internet's longest-serving PC e-mail system!
Welcome to Pegasus Mail & Mercury Sign in | Join | Help
in
Home Blogs Forums Downloads Pegasus Mail Overview Mercury Overview Wiki

Anyone have ClamAV 0.100.0 working?

Last post 04-23-2018, 18:56 by Brian Fluet. 4 replies.
Sort Posts: Previous Next
  •  04-19-2018, 2:06

    • Brian Fluet is not online. Last active: 09-22-2018, 21:03 Brian Fluet
    • Top 10 Contributor
    • Joined on 12-24-2014
    • North Carolina, USA
    • SuperStar
    • Points 21,845

    Anyone have ClamAV 0.100.0 working?

    If anyone has ClamAV 0.100.0 working please let me know how you went about upgrading from 0.99.4.

    Also, can anyone tell me whether a 64bit Visual C++ 2015 installed with a 32bit ClamAV will cause a problem (running on a Win7-64 machine)?  I ran out of time for extensive troubleshooting so had to revert but I think I saw this installation combination which struck me as odd.

    TIA!

    Edit:  Got it working but ended up going about it in a roundabout way so remain curious what others are doing for their upgrade procedure.

  •  04-22-2018, 22:03

    AW: Anyone have ClamAV 0.100.0 working?

    Hello Brian,

    You can also install the new version manually:

     

    msiexec /a  ClamAV-0.100.0-x86.msi /qn TARGETDIR="D:\<Mercury>\ClamWin\"

     

    I will test the v1.00 in the next few days, but I am surprised that the OpenSLL version used (from 2016?) is very very old.

     

    PS: v0.99 was for VC10 runtimes, now it's compiled with VC14

     

     


  •  04-23-2018, 3:31

    • Brian Fluet is not online. Last active: 09-22-2018, 21:03 Brian Fluet
    • Top 10 Contributor
    • Joined on 12-24-2014
    • North Carolina, USA
    • SuperStar
    • Points 21,845

    Re: AW: Anyone have ClamAV 0.100.0 working?

    Extracting the .msi is what I do.  In previous version of ClamAV the C++ runtime library files were packaged in the .msi.  Not so in 0.100.0. 

    The download .zip contains a setup.exe file as well as the .msi.  It checks for Visual C++ and installs it if needed.

    I avoided installing Visual C++ by extracting the .msi then running Clamd.  It would fail looking for a .dll which I would locate on one of the office PC's.  Copy that one then run again to identify the other one.  It started working once I had both .dll files in place.

  •  04-23-2018, 17:52

    Re: Anyone have ClamAV 0.100.0 working?

    Hello Brian,

    You should install the complete VC14 runtime:

     

    https://www.microsoft.com/en-us/download/details.aspx?id=53840

  •  04-23-2018, 18:56

    • Brian Fluet is not online. Last active: 09-22-2018, 21:03 Brian Fluet
    • Top 10 Contributor
    • Joined on 12-24-2014
    • North Carolina, USA
    • SuperStar
    • Points 21,845

    Re: Anyone have ClamAV 0.100.0 working?

    You can tell I'm resistant to installing VC.  Even more so after seeing some of the office machines with 6 versions installed.  This machine only has Mercury and Firefox installed.  It's sole purpose is to run Mercury and provide online banking access.  It's a lean, clean, rock solid machine.
View as RSS news feed in XML

Contact | Advertise | Host provider: PraktIT | Terms of Use | Privacy Statement
Copyright © 2007-2011 David Harris / Peter Strömblad. | Pegasus Mail Home Page