Pegasus Mail & Mercury

Welcome to the Community for Pegasus Mail and
The Mercury Mail Transport System, the Internet's longest-serving PC e-mail system!
Welcome to Pegasus Mail & Mercury Sign in | Join | Help
in
Home Blogs Forums Downloads Pegasus Mail Overview Mercury Overview Wiki

Error message STARTTLS not enabled by administrator

Last post 05-02-2018, 13:43 by FJR. 4 replies.
Sort Posts: Previous Next
  •  04-28-2018, 20:44

    • Gert F. is not online. Last active: 04-29-2018, 12:03 Gert F.
    • Not Ranked
    • Joined on 04-28-2018
    • Member
    • Points 55

    Error message STARTTLS not enabled by administrator

    Hallo,

    when I try to send a mail, I get the message
    SMTP INBOUND: "502 STARTTLS not enabled by administrator."
    Where/how can I enable STARTTLS?

     

  •  04-28-2018, 23:21

    • Rolf Lindby is not online. Last active: 2018-07-18, 3:18 Rolf Lindby
    • Top 10 Contributor
    • Joined on 05-08-2007
    • Stockholm, Sweden
    • SuperStar
    • Points 25,835
    • BetaTeam Moderator SystemAdministrator

    Re: Error message STARTTLS not enabled by administrator

    To enable SSL support for SMTP in Mercury go to Configuration / MercuryS SMTP Server / SSL.

     

  •  04-29-2018, 11:26

    • Gert F. is not online. Last active: 04-29-2018, 12:03 Gert F.
    • Not Ranked
    • Joined on 04-28-2018
    • Member
    • Points 55

    Re: Error message STARTTLS not enabled by administrator

    Thanks,

    I've had a lttle progress.

    Now I get the message

    2018-04-29 08:55:05 Connection failed. Error #2: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert handshake failure [D:\testl\PHPMailer\src\SMTP.php line 404]
    SMTP Error: Could not connect to SMTP host.

    SMTP.php looks like this:

    399        // Begin encrypted connection
    400        set_error_handler([$this, 'errorHandler']);
    401        $crypto_ok = stream_socket_enable_crypto(
    402            $this->smtp_conn,
    403            true,
    404            $crypto_method
    405        );
    406        restore_error_handler();

     

     

  •  04-29-2018, 20:03

    • Rolf Lindby is not online. Last active: 2018-07-18, 3:18 Rolf Lindby
    • Top 10 Contributor
    • Joined on 05-08-2007
    • Stockholm, Sweden
    • SuperStar
    • Points 25,835
    • BetaTeam Moderator SystemAdministrator

    Re: Error message STARTTLS not enabled by administrator

    We probably can't help much with the php client side, but if you check the MercuryS log file there could be some helpful information there.

     

  •  05-02-2018, 13:43

    • FJR is not online. Last active: 2018-06-08, 9:22 FJR
    • Top 25 Contributor
    • Joined on 05-10-2007
    • Dortmund / Germany
    • Star
    • Points 7,300

    Re: Error message STARTTLS not enabled by administrator

    Which version  of Merucry? If not V4.8 you should update to have OpenSSL.

    Now I get the message

    2018-04-29 08:55:05 Connection failed. Error #2: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert handshake failure [D:\testl\PHPMailer\src\SMTP.php line 404]
    SMTP Error: Could not connect to SMTP host.

     If this is with Mercury 4.8, You should check the settings of Module SmtpS. Usualy StartTLS is port 537 while SSL is port 465. Perhaps because of error on deprecated SSL V3 you have to enable "Support for deprecated  direct-connect SSL".And you have to insert or create an certificate file

    bye   Olaf
View as RSS news feed in XML

Contact | Advertise | Host provider: PraktIT | Terms of Use | Privacy Statement
Copyright © 2007-2011 David Harris / Peter Strömblad. | Pegasus Mail Home Page