Community Discussions and Support
Pasting text issue

Hi All,


Just updated to Pegasus Mail 4.8 and have noticed that when I copy and paste text into a new plain text message (with all the Pegasus mail settings set to plain text, etc), the text still gets pasted in with the font type, size, etc, etc copied from.


This didnt use to happen with Peg 4.73 (or any previous version), as it would strip out the font, size, etc and just paste the plain text.


However when the message is sent, the received email does just consist of plain text, and the email in the sent folder is also just plain text.


Maybe just a graphical quirk? but if this could be fixed in the next update that would make things less confusing.


Many thanks


PS. When I had to register for this site, and received the email (in Pegasus Mail) to say that I had to confirm my email address, the link you have to visit isnt a hyperlink and I had to copy and paste it to get it to work!


Hi All, Just updated to Pegasus Mail 4.8 and have noticed that when I copy and paste text into a new plain text message (with all the Pegasus mail settings set to plain text, etc), the text still gets pasted in with the font type, size, etc, etc copied from. This didnt use to happen with Peg 4.73 (or any previous version), as it would strip out the font, size, etc and just paste the plain text. However when the message is sent, the received email does just consist of plain text, and the email in the sent folder is also just plain text. Maybe just a graphical quirk? but if this could be fixed in the next update that would make things less confusing. Many thanks PS. When I had to register for this site, and received the email (in Pegasus Mail) to say that I had to confirm my email address, the link you have to visit isnt a hyperlink and I had to copy and paste it to get it to work!
edited Mar 10 at 11:22 pm

Maybe just a graphical quirk? but if this could be fixed in the next update that would make things less confusing.


I'll see what I can do about it.


the link you have to visit isnt a hyperlink and I had to copy and paste it to get it to work!

Can you please explain what exactly you get? Is it a plain text or HTML formatted message? And if the former, do you have hyperlink detection enabled on Pegasus Mail's Tools => Options => Incoming mail => Hyperlinks? And for the latter: Do you have ... display the fancy version enabled on Tools => Options => Message reader?


[quote="pid:53558, uid:31884"]Maybe just a graphical quirk? but if this could be fixed in the next update that would make things less confusing.[/quote] I'll see what I can do about it. [quote="pid:53558, uid:31884"]the link you have to visit isnt a hyperlink and I had to copy and paste it to get it to work![/quote] Can you please explain what exactly you get? Is it a plain text or HTML formatted message? And if the former, do you have hyperlink detection enabled on Pegasus Mail's _Tools => Options => Incoming mail => Hyperlinks_? And for the latter: Do you have _... display the fancy version_ enabled on _Tools => Options => Message reader_?

			Michael

--
PGP Key ID (RSA 2048): 0xC45D831B
IERenderer's Home: https://www.pmpgp.de/renderer/History.htm
S/MIME Fingerprint: 94C6B471 0C623088 A5B27701 742B8666 3B7E657C

Michael,
While testing what SgtAWilson reported I found another anomaly for you to look into. It pertains to the paste-special options for pasting plain text. If I paste-special plain text not wrapped and then paste-special again wrapped, that second paste will also paste unwrapped. But if my first paste is a paste-special plain text wrapped, then all subsequent paste-special plain text events work as expected.


Michael, While testing what SgtAWilson reported I found another anomaly for you to look into. It pertains to the paste-special options for pasting plain text. If I paste-special plain text not wrapped and then paste-special again wrapped, that second paste will also paste unwrapped. But if my first paste is a paste-special plain text wrapped, then all subsequent paste-special plain text events work as expected.

Can you please explain what exactly you get? Is it a plain text or HTML formatted message? And if the former, do you have hyperlink detection enabled on Pegasus Mail's Tools => Options => Incoming mail => Hyperlinks? And for the latter: Do you have ... display the fancy version enabled on Tools => Options => Message reader?


Yes, I do have both those options on, but the email sent out from the Community system doesnt have a fancy version to display, from what I could see, as there was no alternative version.


This is a minor thing really though compared to the actual PMail issue I mentioned.


[quote="pid:53559, uid:2133"]Can you please explain what exactly you get? Is it a plain text or HTML formatted message? And if the former, do you have hyperlink detection enabled on Pegasus Mail's Tools => Options => Incoming mail => Hyperlinks? And for the latter: Do you have ... display the fancy version enabled on Tools => Options => Message reader?[/quote] Yes, I do have both those options on, but the email sent out from the Community system doesnt have a fancy version to display, from what I could see, as there was no alternative version. This is a minor thing really though compared to the actual PMail issue I mentioned.

I believe that the problem you describe was identified and fixed early in the life of this forum. This is the discussion in which it was confirmed as fixed. If you registered after the fix then the problem may have returned.
https://community.pmail.com/index.php?u=/topic/11470/community-notification-emails/post-52968#post-52968


I believe that the problem you describe was identified and fixed early in the life of this forum. This is the discussion in which it was confirmed as fixed. If you registered after the fix then the problem may have returned. https://community.pmail.com/index.php?u=/topic/11470/community-notification-emails/post-52968#post-52968
edited Mar 11 at 12:48 pm

I believe that the problem you describe was identified and fixed early in the life of this forum. This is the discussion in which it was confirmed as fixed. If you registered after the fix then the problem may have returned.
https://community.pmail.com/index.php?u=/topic/11470/community-notification-emails/post-52968#post-52968


Its a similar issue, but my separate forum one relates to the initial email from forum when you first register and have to click on the link - which you cant and have to copy and paste - to confirm your email address.


[quote="pid:53563, uid:28772"]I believe that the problem you describe was identified and fixed early in the life of this forum. This is the discussion in which it was confirmed as fixed. If you registered after the fix then the problem may have returned. https://community.pmail.com/index.php?u=/topic/11470/community-notification-emails/post-52968#post-52968[/quote] Its a similar issue, but my separate forum one relates to the initial email from forum when you first register and have to click on the link - which you cant and have to copy and paste - to confirm your email address.

If I paste-special plain text not wrapped and then paste-special again wrapped, that second paste will also paste unwrapped. But if my first paste is a paste-special plain text wrapped, then all subsequent paste-special plain text events work as expected.


I'm not sure there's the issue you think it is, Brian, as I believe you're actually describing the default behaviour of a Rich Text editor, i.e. the fact that its paragraph formatting is attached to the respective paragraph's enclosing (invisible) "hard" line break characters: This results in making a difference in whether there's a blank line between the current and surrounding paragraphs, to get a sample you may try the following: After pasting in some unwrapped long line text in the very first position of the editor go back to the same first position and press the Return key repeatedly, then go back to this position again and try to paste in the same text with line wrapping enabled: You will still get a non-wrapped paste because by hitting the return key you "extended" the already existing paragraph formatting which is then applied to the newly inserted text. The same will happen if pasting in behind the unwrapped paragraph after just hitting the Return key as often as you wish to.


There are two ways to change this behaviour: On top of the message you need to hit Ctrl + J (resetting to default) on some text separated by a blank line from the pasted text (just some characters will do) and at the bottom - supposed you already have your signature inserted - use the arrow key to go down to the first line behind a blank one before pasting. After doing so the line wrapping will be properly applied on the pasted text again, i.e. it depends on the exact location where it's being inserted.


I don't know whether it's always been like this, but it's certainly TER doing the insertion handling, that's for sure.


[quote="pid:53560, uid:28772"]If I paste-special plain text not wrapped and then paste-special again wrapped, that second paste will also paste unwrapped. But if my first paste is a paste-special plain text wrapped, then all subsequent paste-special plain text events work as expected.[/quote] I'm not sure there's the issue you think it is, Brian, as I believe you're actually describing the default behaviour of a Rich Text editor, i.e. the fact that its paragraph formatting is attached to the respective paragraph's enclosing (invisible) "hard" line break characters: This results in making a difference in whether there's a blank line between the current and surrounding paragraphs, to get a sample you may try the following: After pasting in some unwrapped long line text in the very first position of the editor go back to the same first position and press the Return key repeatedly, then go back to this position again and try to paste in the same text with line wrapping enabled: You will still get a non-wrapped paste because by hitting the return key you "extended" the already existing paragraph formatting which is then applied to the newly inserted text. The same will happen if pasting in behind the unwrapped paragraph after just hitting the Return key as often as you wish to. There are two ways to change this behaviour: On top of the message you need to hit Ctrl + J (resetting to default) on some text separated by a blank line from the pasted text (just some characters will do) and at the bottom - supposed you already have your signature inserted - use the arrow key to go down to the first line behind a blank one before pasting. After doing so the line wrapping will be properly applied on the pasted text again, i.e. it depends on the exact location where it's being inserted. I don't know whether it's always been like this, but it's certainly TER doing the insertion handling, that's for sure.

			Michael

--
PGP Key ID (RSA 2048): 0xC45D831B
IERenderer's Home: https://www.pmpgp.de/renderer/History.htm
S/MIME Fingerprint: 94C6B471 0C623088 A5B27701 742B8666 3B7E657C
edited Mar 12 at 3:45 pm

In my Pmail-Editor I have to press Strg+0 to set back the style to default. smile


For long Text with different formats it could be helpfull to have an option to show the invisible format control characters, like in word.


In my Pmail-Editor I have to press Strg+0 to set back the style to default. ;) For long Text with different formats it could be helpfull to have an option to show the invisible format control characters, like in word.

Pegasus v4.8 DE - Win10 pro

In my Pmail-Editor I have to press Strg+0 to set back the style to default


Are you using any of the right-click > Paste special > Text only options?


[quote="pid:53566, uid:29380"]In my Pmail-Editor I have to press Strg+0 to set back the style to default[/quote] Are you using any of the right-click > Paste special > Text only options?

Yes, that what this thread is about or? smile


The thing is when you special paste a text without wrapping then all following pasted text will have also this format "no wrapping" regardless if you paste with or without wrap.
When you now mark one or two lines below the pasted text and set back style with Strg+0 or right click "set back the style" then you can special paste also text with line wrap.


Not sure but normal it should be possible to change the special paste functions in that way that the editor automatically set back the style for the new lines which will be pasted.


Yes, that what this thread is about or? ;) The thing is when you special paste a text without wrapping then all following pasted text will have also this format "no wrapping" regardless if you paste with or without wrap. When you now mark one or two lines below the pasted text and set back style with Strg+0 or right click "set back the style" then you can special paste also text with line wrap. Not sure but normal it should be possible to change the special paste functions in that way that the editor automatically set back the style for the new lines which will be pasted.

Pegasus v4.8 DE - Win10 pro

Not sure but normal it should be possible to change the special paste functions in that way that the editor automatically set back the style for the new lines which will be pasted.


Agreed! A carriage return is enough to reset it after pasting formatted text but not after pasting text only, not wordwrapped. Even a double carriage return is not enough.


We are stuck with it with TER being the cause although I doubt I would ever encounter it in day-to-day use.


[quote="pid:53571, uid:29380"]Not sure but normal it should be possible to change the special paste functions in that way that the editor automatically set back the style for the new lines which will be pasted.[/quote] Agreed! A carriage return is enough to reset it after pasting formatted text but not after pasting text only, not wordwrapped. Even a double carriage return is not enough. We are stuck with it with TER being the cause although I doubt I would ever encounter it in day-to-day use.

I have a very similar problem with 4.8.1028 using the IE renderer.
When I paste rich text into a mail, Pegasus Mail sometimes crashes.
And the other way round, pasting of text that I copy from an email sometimes doesn't work in other programs, for example in the Outlook calendar.


I have a very similar problem with 4.8.1028 using the IE renderer. When I paste rich text into a mail, Pegasus Mail sometimes crashes. And the other way round, pasting of text that I copy from an email sometimes doesn't work in other programs, for example in the Outlook calendar.

I have a very similar problem with 4.8.1028 using the IE renderer.

Can you please start a new thread about this so we can handle it separately? It's not similar and we need to handle it in a different way. I'll get back to you about what to do next when I have the necessary debugging database I need for handling it once v4.81 is out and you'll have updated to it.


[quote="pid:53581, uid:31885"]I have a very similar problem with 4.8.1028 using the IE renderer.[/quote] Can you please start a new thread about this so we can handle it separately? It's not similar and we need to handle it in a different way. I'll get back to you about what to do next when I have the necessary debugging database I need for handling it once v4.81 is out and you'll have updated to it.

			Michael

--
PGP Key ID (RSA 2048): 0xC45D831B
IERenderer's Home: https://www.pmpgp.de/renderer/History.htm
S/MIME Fingerprint: 94C6B471 0C623088 A5B27701 742B8666 3B7E657C
edited Mar 13 at 3:23 pm

Ok, I will do so.
Thanks for having a look at it!


Ok, I will do so. Thanks for having a look at it!

Agreed! A carriage return is enough to reset it after pasting formatted text but not after pasting text only, not wordwrapped. Even a double carriage return is not enough

I don't remember whether I commented on this elsewhere: It's an issue David Harris needs to deal with (already reported) since I can't fix it in IER.


[quote="pid:53575, uid:28772"]Agreed! A carriage return is enough to reset it after pasting formatted text but not after pasting text only, not wordwrapped. Even a double carriage return is not enough[/quote] I don't remember whether I commented on this elsewhere: It's an issue David Harris needs to deal with (already reported) since I can't fix it in IER.

			Michael

--
PGP Key ID (RSA 2048): 0xC45D831B
IERenderer's Home: https://www.pmpgp.de/renderer/History.htm
S/MIME Fingerprint: 94C6B471 0C623088 A5B27701 742B8666 3B7E657C

Maybe just a graphical quirk? but if this could be fixed in the next update that would make things less confusing.

Another issue David Harris needs to work on (reported as well), I can't figure out a workaround for IER.


[quote="pid:53558, uid:31884"]Maybe just a graphical quirk? but if this could be fixed in the next update that would make things less confusing.[/quote] Another issue David Harris needs to work on (reported as well), I can't figure out a workaround for IER.

			Michael

--
PGP Key ID (RSA 2048): 0xC45D831B
IERenderer's Home: https://www.pmpgp.de/renderer/History.htm
S/MIME Fingerprint: 94C6B471 0C623088 A5B27701 742B8666 3B7E657C
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft