Community Discussions and Support
Pegasus Mail Send to Myself

Hi,


I'm trying to send an email from me to me. Even though pegasus seems to have sent it and a copy can be found in the Copy To Self folder, the email never reaches the inbox.


I checked on the web access of my email providers with 2 different email addresses and providers - email is not there also not in the junk folder. When sending email to myself via the web interface it's working - the problem is only via Pegasus UI.


For other recepients it's working properly.


Is there any way to make it work?


Thanks,
Barry


Hi, I'm trying to send an email from me to me. Even though pegasus seems to have sent it and a copy can be found in the Copy To Self folder, the email never reaches the inbox. I checked on the web access of my email providers with 2 different email addresses and providers - email is not there also not in the junk folder. When sending email to myself via the web interface it's working - the problem is only via Pegasus UI. For other recepients it's working properly. Is there any way to make it work? Thanks, Barry

I once encountered an SMTP provider who would not process sent mail that contained the same From and To addresses. I don't remember which one it was but I recall not being able to overcome the problem.


I once encountered an SMTP provider who would not process sent mail that contained the same From and To addresses. I don't remember which one it was but I recall not being able to overcome the problem.

Dear Brian, thanks for the prompt reply. As I wrote earlier, this is not the case because I tried directly on the web access of the providers - 2 different providers with 2 different email accounts and it is working there.
This problem happens only when sending via the Pegasus mail interface.


Dear Brian, thanks for the prompt reply. As I wrote earlier, this is not the case because I tried directly on the web access of the providers - 2 different providers with 2 different email accounts and it is working there. This problem happens only when sending via the Pegasus mail interface.

The web interface works different from Pegasus Mail. Pegasus Mail submits the message to an SMTP server. My suspicion is that the SMTP server accepts the message (no error or rejection notice on Pegasus Mail end), then detects the identical From/To and does not process the message.


The web interface works different from Pegasus Mail. Pegasus Mail submits the message to an SMTP server. My suspicion is that the SMTP server accepts the message (no error or rejection notice on Pegasus Mail end), then detects the identical From/To and does not process the message.

Would suggest tools / internet options and click on the create log files.


Then attempt sending email, and then look at TCPlogs subdirectory.


It might provided data on connection.


You are using the @ in the email address??
If you can using the local user name, then it isn't and internet email, and Pegasus would deliver it differently.


Recall on Novell networks, Pegasus would handle all email send to other network users via the Binary or NDS of the Novell, and only use the internet if @ in address.
Did an uucp gate for Pegasus many many years ago, and it used a different process to do the same.


Would suggest tools / internet options and click on the create log files. Then attempt sending email, and then look at TCPlogs subdirectory. It might provided data on connection. You are using the @ in the email address?? If you can using the local user name, then it isn't and internet email, and Pegasus would deliver it differently. Recall on Novell networks, Pegasus would handle all email send to other network users via the Binary or NDS of the Novell, and only use the internet if @ in address. Did an uucp gate for Pegasus many many years ago, and it used a different process to do the same.

Thanks for your idea, msetzerii, but it didn't help.


The TCPlogs folder does not exist, I created it (as well as TCPlog folder) manually, but no log files appeared there.


I am using the full email address name@domain.com


However, the strangest thing happened, out of 5 test emails, only the second landed in the inbox. All emails arrived to the email address specified in cc field.


Tested with Pegasus Mail version 4.73 and 4.8 on Windows 10 Pro.


Thanks for your idea, msetzerii, but it didn't help. The TCPlogs folder does not exist, I created it (as well as TCPlog folder) manually, but no log files appeared there. I am using the full email address name@domain.com However, the strangest thing happened, out of 5 test emails, only the second landed in the inbox. All emails arrived to the email address specified in cc field. Tested with Pegasus Mail version 4.73 and 4.8 on Windows 10 Pro.

The TCPlogs folder does not exist, I created it (as well as TCPlog folder) manually, but no log files appeared there.

It does not exist by default. It gets created automatically when a log file is created. You must enable internet session logging which is a tickbox located at the bottom of the General tab in Tools | Internet Options. Don't forget to turn it back off.


However, the strangest thing happened, out of 5 test emails, only the second landed in the inbox. All emails arrived to the email address specified in cc field.


I don't have an explanation for why the second on landed in the inbox but at least you now know the you can send messages to yourself using cc.


[quote="pid:54669, uid:28344"]The TCPlogs folder does not exist, I created it (as well as TCPlog folder) manually, but no log files appeared there.[/quote] It does not exist by default. It gets created automatically when a log file is created. You must enable internet session logging which is a tickbox located at the bottom of the General tab in Tools | Internet Options. Don't forget to turn it back off. [quote="pid:54669, uid:28344"]However, the strangest thing happened, out of 5 test emails, only the second landed in the inbox. All emails arrived to the email address specified in cc field.[/quote] I don't have an explanation for why the second on landed in the inbox but at least you now know the you can send messages to yourself using cc.

It does not exist by default. It gets created automatically when a log file is created. You must enable internet session logging which is a tickbox located at the bottom of the General tab in Tools | Internet Options. Don't forget to turn it back off.


I thought it was clear I enabled it before sending the emails. I also noticed that when closing Pegasus Mail and reopening it disables.


I don't have an explanation for why the second on landed in the inbox but at least you now know the you can send messages to yourself using cc.


My email address was in the To box, in the Cc I had 2 other emails, one on a different domain and another email on the same domain as the sender just as control to see the email was really sent.


Email to myself didn't reach my inbox, no matter where it was written, To, Cc or Bcc.


[quote="pid:54671, uid:28772"]It does not exist by default. It gets created automatically when a log file is created. You must enable internet session logging which is a tickbox located at the bottom of the General tab in Tools | Internet Options. Don't forget to turn it back off.[/quote] I thought it was clear I enabled it before sending the emails. I also noticed that when closing Pegasus Mail and reopening it disables. [quote="pid:54671, uid:28772"]I don't have an explanation for why the second on landed in the inbox but at least you now know the you can send messages to yourself using cc.[/quote] My email address was in the To box, in the Cc I had 2 other emails, one on a different domain and another email on the same domain as the sender just as control to see the email was really sent. Email to myself didn't reach my inbox, no matter where it was written, To, Cc or Bcc.

The TCPlogs folder does not exist, I created it (as well as TCPlog folder) manually, but no log files appeared there.


Just posting to confirm that you looked for the TCPLogs folder in the mailbox directory.


If you find it, don't post the entire content of a log file. They contain login credentials. They may be encoded but they're in easily decoded base64.


[quote="pid:54669, uid:28344"]The TCPlogs folder does not exist, I created it (as well as TCPlog folder) manually, but no log files appeared there.[/quote] Just posting to confirm that you looked for the TCPLogs folder in the mailbox directory. If you find it, don't post the entire content of a log file. They contain login credentials. They may be encoded but they're in easily decoded base64.

Thanks Brian, I was looking for the TCPLogs in the program folder.


Here are the lines from the log (I replaced parts of the email addresses with x):


14:50:54.799: << MAIL FROM:hxxx@hxxx.com SIZE=481<cr><lf>
14:50:55.077: >> 250 OK<cr><lf>
14:50:55.081: << RCPT TO:bxxx@nxxx.com<cr><lf>
14:50:55.734: >> 250 OK<cr><lf>
14:50:55.738: << DATA<cr><lf>
14:50:55.932: >> 354 Ready<cr><lf>
14:50:55.940: << From: "Hxxx" hxxx@hxxx.com<cr><lf>
14:50:55.947: << To: <cr><lf>
14:50:55.950: << Date: Wed, 09 Nov 2022 14:50:48 +0100<cr><lf>
14:50:55.956: << MIME-Version: 1.0<cr><lf>
14:50:55.960: << Subject: Test Email to Self 01<cr><lf>
14:50:55.965: << Reply-to: hxxx@hxxx.com<cr><lf>
14:50:55.969: << CC: bxxx@nxxx.com<cr><lf>
14:50:55.973: << Message-ID: 636BB038.9549.6B66ACD7@hxxx.hxxx.com<cr><lf>
14:50:55.976: << Priority: normal<cr><lf>
14:50:55.981: << X-mailer: Pegasus Mail for Windows (4.80.102smile<cr><lf>
14:50:55.986: << Content-type: text/plain; charset=US-ASCII<cr><lf>
14:50:55.990: << Content-transfer-encoding: 7BIT<cr><lf>
14:50:55.994: << Content-description: Mail message body<cr><lf>
14:50:55.998: << <cr><lf>
14:50:56.004: << Test Email to Self 01<cr><lf>
14:50:56.009: << .<cr><lf>
14:50:56.301: >> 250 2.6.0 Message accepted with ID 75e0f24e-1725eed8f07fd0d4<cr><lf>
14:50:56.327: << RSET<cr><lf>
14:50:56.521: >> 250 OK<cr><lf>


As I understand from the log, Pegasus Mail does not fill-in the To field (14:50:55.947), the email arrive to bxxx@nxxx.com


Thanks Brian, I was looking for the TCPLogs in the program folder. Here are the lines from the log (I replaced parts of the email addresses with x): 14:50:54.799: &lt;&lt; MAIL FROM:&lt;hxxx@hxxx.com&gt; SIZE=481&lt;cr&gt;&lt;lf&gt; 14:50:55.077: &gt;&gt; 250 OK&lt;cr&gt;&lt;lf&gt; 14:50:55.081: &lt;&lt; RCPT TO:&lt;bxxx@nxxx.com&gt;&lt;cr&gt;&lt;lf&gt; 14:50:55.734: &gt;&gt; 250 OK&lt;cr&gt;&lt;lf&gt; 14:50:55.738: &lt;&lt; DATA&lt;cr&gt;&lt;lf&gt; 14:50:55.932: &gt;&gt; 354 Ready&lt;cr&gt;&lt;lf&gt; 14:50:55.940: &lt;&lt; From: &quot;Hxxx&quot; &lt;hxxx@hxxx.com&gt;&lt;cr&gt;&lt;lf&gt; 14:50:55.947: &lt;&lt; To: &lt;cr&gt;&lt;lf&gt; 14:50:55.950: &lt;&lt; Date: Wed, 09 Nov 2022 14:50:48 +0100&lt;cr&gt;&lt;lf&gt; 14:50:55.956: &lt;&lt; MIME-Version: 1.0&lt;cr&gt;&lt;lf&gt; 14:50:55.960: &lt;&lt; Subject: Test Email to Self 01&lt;cr&gt;&lt;lf&gt; 14:50:55.965: &lt;&lt; Reply-to: hxxx@hxxx.com&lt;cr&gt;&lt;lf&gt; 14:50:55.969: &lt;&lt; CC: bxxx@nxxx.com&lt;cr&gt;&lt;lf&gt; 14:50:55.973: &lt;&lt; Message-ID: &lt;636BB038.9549.6B66ACD7@hxxx.hxxx.com&gt;&lt;cr&gt;&lt;lf&gt; 14:50:55.976: &lt;&lt; Priority: normal&lt;cr&gt;&lt;lf&gt; 14:50:55.981: &lt;&lt; X-mailer: Pegasus Mail for Windows (4.80.1028)&lt;cr&gt;&lt;lf&gt; 14:50:55.986: &lt;&lt; Content-type: text/plain; charset=US-ASCII&lt;cr&gt;&lt;lf&gt; 14:50:55.990: &lt;&lt; Content-transfer-encoding: 7BIT&lt;cr&gt;&lt;lf&gt; 14:50:55.994: &lt;&lt; Content-description: Mail message body&lt;cr&gt;&lt;lf&gt; 14:50:55.998: &lt;&lt; &lt;cr&gt;&lt;lf&gt; 14:50:56.004: &lt;&lt; Test Email to Self 01&lt;cr&gt;&lt;lf&gt; 14:50:56.009: &lt;&lt; .&lt;cr&gt;&lt;lf&gt; 14:50:56.301: &gt;&gt; 250 2.6.0 Message accepted with ID 75e0f24e-1725eed8f07fd0d4&lt;cr&gt;&lt;lf&gt; 14:50:56.327: &lt;&lt; RSET&lt;cr&gt;&lt;lf&gt; 14:50:56.521: &gt;&gt; 250 OK&lt;cr&gt;&lt;lf&gt; As I understand from the log, Pegasus Mail does not fill-in the To field (14:50:55.947), the email arrive to bxxx@nxxx.com

I have never seen a blank To: header like that nor can I recreate it. For me, if I attempt to send a message with a blank To: field, a dialog pops up asking whether I really want to send it. When I click Yes, the message is rejected by my SMTP provider.


I am clueless at the moment about what is causing this. I will be back with any thoughts that may bubble up.


I have never seen a blank To: header like that nor can I recreate it. For me, if I attempt to send a message with a blank To: field, a dialog pops up asking whether I really want to send it. When I click Yes, the message is rejected by my SMTP provider. I am clueless at the moment about what is causing this. I will be back with any thoughts that may bubble up.

I do type the email address (mine) in the To box on Pegasus' user interface, but it seems that Pegasus just doesn't use it when actually sending the email.


Thanks anyway.


I do type the email address (mine) in the To box on Pegasus&#039; user interface, but it seems that Pegasus just doesn&#039;t use it when actually sending the email. Thanks anyway.
edited Nov 9 '22 at 5:48 pm
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft