Community Discussions and Support
Plato

When you make changes to the rquotes.r *source* file, you then have to compile it with the RESCOM.EXE utility, which ships with Pegasus Mail in the Resources subfolder under the Pegasus Mail program directory (usually C:\PMAIL), and then copy the resulting rquotes.rsc resource file to your mailbox directory as an rquotes.pms file.

From the sample rquotes.r file:

##
##   Sample source for a suitable RQUOTES.PMS for use in
##   Pegasus Mail v3.0/WinPmail variable signatures.
##
##   Compile this source using ResCom.exe, by issuing the
##   command "ResCom RQUOTES.R", then copy the resulting
##   RQUOTES.RSC file into your home mailbox as RQUOTES.PMS.
##
##   So, the sequence of commands looks like this:
##
##      C:\PMAIL> rescom rquotes.r
##      C:\PMAIL> copy rquotes.rsc f:\mail\9000001\rquotes.pms
##
##   The general format of this file is a collection of text
##   resources; each text resource is a multiline group of
##   quoted strings, ending with \n wherever you want a line
##   break.
##
##   To activate your variable signature, place the characters
##   ~! in your signature file at the point where you want the
##   substitution to occur.
##

In the example above, F:\mail\9000001\ is presumed to be your mailbox directory (as it would be in a NetWare bindery mode environment).  More likely, it will be something like C:\PMAIL\MAIL\Fred.

 

<P>When you make changes to the rquotes.r *source* file, you then have to compile it with the RESCOM.EXE utility, which ships with Pegasus Mail in the Resources subfolder under the Pegasus Mail program directory (usually C:\PMAIL), and then copy the resulting rquotes.rsc resource file to your mailbox directory as an rquotes.pms file.</P> <P>From the sample rquotes.r file:</P> <P>## ##   Sample source for a suitable RQUOTES.PMS for use in ##   Pegasus Mail v3.0/WinPmail variable signatures. ## ##   Compile this source using ResCom.exe, by issuing the ##   command "ResCom RQUOTES.R", then copy the resulting ##   RQUOTES.RSC file into your home mailbox as RQUOTES.PMS. ## ##   So, the sequence of commands looks like this: ## ##      C:\PMAIL> rescom rquotes.r ##      C:\PMAIL> copy rquotes.rsc f:\mail\9000001\rquotes.pms ## ##   The general format of this file is a collection of text ##   resources; each text resource is a multiline group of ##   quoted strings, ending with \n wherever you want a line ##   break. ## ##   To activate your variable signature, place the characters ##   ~! in your signature file at the point where you want the ##   substitution to occur. ##</P> <P>In the example above, F:\mail\9000001\ is presumed to be your mailbox directory (as it would be in a NetWare bindery mode environment).  More likely, it will be something like C:\PMAIL\MAIL\Fred.</P> <P mce_keep="true"> </P>

When you make changes to the rquotes.r *source* file, you then have to compile it with the RESCOM.EXE utility, which ships with Pegasus Mail in the Resources subfolder under the Pegasus Mail program directory (usually C:\PMAIL), and then copy the resulting rquotes.rsc resource file to your mailbox directory as an rquotes.pms file.

From the sample rquotes.r file:

##
##   Sample source for a suitable RQUOTES.PMS for use in
##   Pegasus Mail v3.0/WinPmail variable signatures.
##
##   Compile this source using ResCom.exe, by issuing the
##   command "ResCom RQUOTES.R", then copy the resulting
##   RQUOTES.RSC file into your home mailbox as RQUOTES.PMS.
##
##   So, the sequence of commands looks like this:
##
##      C:\PMAIL> rescom rquotes.r
##      C:\PMAIL> copy rquotes.rsc f:\mail\9000001\rquotes.pms
##
##   The general format of this file is a collection of text
##   resources; each text resource is a multiline group of
##   quoted strings, ending with \n wherever you want a line
##   break.
##
##   To activate your variable signature, place the characters
##   ~! in your signature file at the point where you want the
##   substitution to occur.
##

In the example above, F:\mail\9000001\ is presumed to be your mailbox directory (as it would be in a NetWare bindery mode environment).  More likely, it will be something like C:\PMAIL\MAIL\Fred.

 

<P>When you make changes to the rquotes.r *source* file, you then have to compile it with the RESCOM.EXE utility, which ships with Pegasus Mail in the Resources subfolder under the Pegasus Mail program directory (usually C:\PMAIL), and then copy the resulting rquotes.rsc resource file to your mailbox directory as an rquotes.pms file.</P> <P>From the sample rquotes.r file:</P> <P>## ##   Sample source for a suitable RQUOTES.PMS for use in ##   Pegasus Mail v3.0/WinPmail variable signatures. ## ##   Compile this source using ResCom.exe, by issuing the ##   command "ResCom RQUOTES.R", then copy the resulting ##   RQUOTES.RSC file into your home mailbox as RQUOTES.PMS. ## ##   So, the sequence of commands looks like this: ## ##      C:\PMAIL> rescom rquotes.r ##      C:\PMAIL> copy rquotes.rsc f:\mail\9000001\rquotes.pms ## ##   The general format of this file is a collection of text ##   resources; each text resource is a multiline group of ##   quoted strings, ending with \n wherever you want a line ##   break. ## ##   To activate your variable signature, place the characters ##   ~! in your signature file at the point where you want the ##   substitution to occur. ##</P> <P>In the example above, F:\mail\9000001\ is presumed to be your mailbox directory (as it would be in a NetWare bindery mode environment).  More likely, it will be something like C:\PMAIL\MAIL\Fred.</P> <P mce_keep="true"> </P>

Does anyone know how to make this addon work?  I have it installed okay but it just doesn't seem to work.

Most of the function keys simply produce error messages while the "send" button causes Pmail to crash.

"compile"  congratulated me and reported plato ready to work with Pmail.  It just doesn't.  What am I missing?

 

 

<P>Does anyone know how to make this addon work?  I have it installed okay but it just doesn't seem to work.</P> <P>Most of the function keys simply produce error messages while the "send" button causes Pmail to crash.</P> <P>"compile"  congratulated me and reported plato ready to work with Pmail.  It just doesn't.  What am I missing?</P> <P mce_keep="true"> </P> <P mce_keep="true"> </P>

I just installed and ran it just fine.  Created a new quote file, stuck in 2 fake quotes, saved it, ran the Compile option (the dos box window appeared briefly during the compile), and it said 2 quotes were compiled and ready to use.  Is there anything different or odd about your Pegasus Mail configuration?

 

<P>I just installed and ran it just fine.  Created a new quote file, stuck in 2 fake quotes, saved it, ran the Compile option (the dos box window appeared briefly during the compile), and it said 2 quotes were compiled and ready to use.  Is there anything different or odd about your Pegasus Mail configuration?</P> <P mce_keep="true"> </P>

I just installed and ran it just fine.  Created a new quote file, stuck in 2 fake quotes, saved it, ran the Compile option (the dos box window appeared briefly during the compile), and it said 2 quotes were compiled and ready to use.  Is there anything different or odd about your Pegasus Mail configuration?

 

<P>I just installed and ran it just fine.  Created a new quote file, stuck in 2 fake quotes, saved it, ran the Compile option (the dos box window appeared briefly during the compile), and it said 2 quotes were compiled and ready to use.  Is there anything different or odd about your Pegasus Mail configuration?</P> <P mce_keep="true"> </P>

[quote user="dkocmoud"]

I just installed and ran it just fine.  Created a new quote file, stuck in 2 fake quotes, saved it, ran the Compile option (the dos box window appeared briefly during the compile), and it said 2 quotes were compiled and ready to use.  Is there anything different or odd about your Pegasus Mail configuration?

 

[/quote]

 Not that I am aware of.  I compiled a quote file as you did and received that same "ready to use" report.  Okay, now what???  That was the last I heard from Plato.  I don't think I am setting it up correctly and may not even unnerstand its true purpose in life.  I am under the impression that Plato is a text compiler that will select random lines of text and paste them at the bottom of an email message.  Is that correct?  If so, it ain't workin'.  Highlighting the quote file in the console and selecting "send" crashes Pmail.  What is the purpose of "send" anyway?   If it is working for you I am all ears.  Help file does nothing but produce "can't display" errors. 

Thanks for your reply

[quote user="dkocmoud"] <P>I just installed and ran it just fine.  Created a new quote file, stuck in 2 fake quotes, saved it, ran the Compile option (the dos box window appeared briefly during the compile), and it said 2 quotes were compiled and ready to use.  Is there anything different or odd about your Pegasus Mail configuration?</P> <P mce_keep="true"> </P> <P>[/quote]</P> <P> Not that I am aware of.  I compiled a quote file as you did and received that same "ready to use" report.  Okay, now what???  That was the last I heard from Plato.  I don't think I am setting it up correctly and may not even unnerstand its true purpose in life.  I am under the impression that Plato is a text compiler that will select random lines of text and paste them at the bottom of an email message.  Is that correct?  If so, it ain't workin'.  Highlighting the quote file in the console and selecting "send" crashes Pmail.  What is the purpose of "send" anyway?   If it is working for you I am all ears.  Help file does nothing but produce "can't display" errors. </P> <P>Thanks for your reply</P>

This is what the Plato Help file has to say about the "Send" button:

Send
It is possible to send quote files to other Pegasus users using this option. When this feature is activated the highlighted quote files are send to the default email client on your system. Mark that if the default email client is not Pegasus, that email client is launched.

However, as you've found out, this option appears to cause Pegasus Mail to hang, so don't use it.  ;-)

It also appears that the author assumes you already know how to use Pegasus Mail's built-in random quotes feature (aka variable signatures).  Basically Plato just provides you with the ability to edit simple lists and then compile the lists into an rquotes.pms random quotes file, ready for use with Pegasus Mail.  The only step you have left to do once to actually use the quotes is to add the following 2 characters somewhere in your Pegasus Mail Internet signature where you'd like the random quote to be inserted:  ~!

Here's the info from the Pegasus Mail Help file:

Variable signatures:  Pegasus Mail can place a piece of text selected at random from a list you provide in your signature -- for more information on preparing a variable signature, examine the sample quotes file RQUOTES.R in the RESOURCE\ subdirectory of the directory where you installed Pegasus Mail. To flag the location in your signature where you want the variable text to be placed, use the special characters ~!. Be careful when using variable signatures -- people's tastes differ hugely all around the world, and something which seems witty to you may be offensive to other people.

Enjoy!

 

<P>This is what the Plato Help file has to say about the "Send" button:</P> <P><SPAN style="FONT-SIZE: 12pt; COLOR: #000000; FONT-FAMILY: Tahoma"><SPAN style="FONT-SIZE: 12pt; COLOR: #0000ff; FONT-FAMILY: Tahoma"><B>Send</B></SPAN></SPAN></SPAN><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma"> It is possible to send quote files to other Pegasus users using this option. When this feature is activated the highlighted quote files are send to the default email client on your system. Mark that if the default email client is not Pegasus, that email client is launched. </SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma">However, as you've found out, this option appears to cause Pegasus Mail to hang, so don't use it.  ;-)</SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma">It also appears that the author assumes you already know how to use Pegasus Mail's built-in random quotes feature (aka variable signatures).  Basically Plato just provides you with the ability to edit simple lists and then compile the lists into an rquotes.pms random quotes file, ready for use with Pegasus Mail.  The only step you have left to do once to actually use the quotes is to add the following 2 characters somewhere in your Pegasus Mail Internet signature where you'd like the random quote to be inserted:  ~!</SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma">Here's the info from the Pegasus Mail Help file:</SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma">Variable signatures:  Pegasus Mail can place a piece of text selected at random from a list you provide in your signature -- for more information on preparing a variable signature, examine the sample quotes file RQUOTES.R in the RESOURCE\ subdirectory of the directory where you installed Pegasus Mail. To flag the location in your signature where you want the variable text to be placed, use the special characters ~!. Be careful when using variable signatures -- people's tastes differ hugely all around the world, and something which seems witty to you may be offensive to other people.</SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma">Enjoy!</SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma"></SPAN> </P>

This is what the Plato Help file has to say about the "Send" button:

Send
It is possible to send quote files to other Pegasus users using this option. When this feature is activated the highlighted quote files are send to the default email client on your system. Mark that if the default email client is not Pegasus, that email client is launched.

However, as you've found out, this option appears to cause Pegasus Mail to hang, so don't use it.  ;-)

It also appears that the author assumes you already know how to use Pegasus Mail's built-in random quotes feature (aka variable signatures).  Basically Plato just provides you with the ability to edit simple lists and then compile the lists into an rquotes.pms random quotes file, ready for use with Pegasus Mail.  The only step you have left to do once to actually use the quotes is to add the following 2 characters somewhere in your Pegasus Mail Internet signature where you'd like the random quote to be inserted:  ~!

Here's the info from the Pegasus Mail Help file:

Variable signatures:  Pegasus Mail can place a piece of text selected at random from a list you provide in your signature -- for more information on preparing a variable signature, examine the sample quotes file RQUOTES.R in the RESOURCE\ subdirectory of the directory where you installed Pegasus Mail. To flag the location in your signature where you want the variable text to be placed, use the special characters ~!. Be careful when using variable signatures -- people's tastes differ hugely all around the world, and something which seems witty to you may be offensive to other people.

Enjoy!

 

<P>This is what the Plato Help file has to say about the "Send" button:</P> <P><SPAN style="FONT-SIZE: 12pt; COLOR: #000000; FONT-FAMILY: Tahoma"><SPAN style="FONT-SIZE: 12pt; COLOR: #0000ff; FONT-FAMILY: Tahoma"><B>Send</B></SPAN></SPAN></SPAN><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma"> It is possible to send quote files to other Pegasus users using this option. When this feature is activated the highlighted quote files are send to the default email client on your system. Mark that if the default email client is not Pegasus, that email client is launched. </SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma">However, as you've found out, this option appears to cause Pegasus Mail to hang, so don't use it.  ;-)</SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma">It also appears that the author assumes you already know how to use Pegasus Mail's built-in random quotes feature (aka variable signatures).  Basically Plato just provides you with the ability to edit simple lists and then compile the lists into an rquotes.pms random quotes file, ready for use with Pegasus Mail.  The only step you have left to do once to actually use the quotes is to add the following 2 characters somewhere in your Pegasus Mail Internet signature where you'd like the random quote to be inserted:  ~!</SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma">Here's the info from the Pegasus Mail Help file:</SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma">Variable signatures:  Pegasus Mail can place a piece of text selected at random from a list you provide in your signature -- for more information on preparing a variable signature, examine the sample quotes file RQUOTES.R in the RESOURCE\ subdirectory of the directory where you installed Pegasus Mail. To flag the location in your signature where you want the variable text to be placed, use the special characters ~!. Be careful when using variable signatures -- people's tastes differ hugely all around the world, and something which seems witty to you may be offensive to other people.</SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma">Enjoy!</SPAN></P> <P><SPAN style="FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Tahoma"></SPAN> </P>

Thanks for the reply but I am having a very bad Pegasus week.   The signature function doesn't work at all now for some reason.  If I get it working I will revisit the Plato issue

 

 

<P>Thanks for the reply but I am having a very bad Pegasus week.   The signature function doesn't work at all now for some reason.  If I get it working I will revisit the Plato issue</P> <P mce_keep="true"> </P> <P mce_keep="true"> </P>

Please note that each signature "set" contains 4 separate possible signature "variants", one of which will be used based upon the type if email and destination address.  Those four signature variants are:

  • Plain text, Internet Recipient
  • Plain text, Local Recipient
  • HTML text, Internet Recipient
  • HTML text, Local Recipient

Now by default the "HTML text, Internet Recipient" is pre-selected for editing when you edit a signature set, but by default, one of the two "Plain text" signature variants is used in an email by default, unless you enable the Rich Text checkbox in an email message or use formatting that automatically enables it.  If you haven't already done so, make sure you've typed a test signature text into all four possible signature "variants" and then try your test.  If signatures are now working, try adding "~!" to all four signature variants and test again to see if the random quote is added to outgoing emails (note that it will not appear on copyself emails, nor does any signature appear in a copyself email).  Use a BCC address to yourself if you want a full copy of exactly what was sent.

 

<P>Please note that each signature "set" contains 4 separate possible signature "variants", one of which will be used based upon the type if email and destination address.  Those four signature variants are:</P> <UL> <LI>Plain text, Internet Recipient</LI> <LI>Plain text, Local Recipient</LI> <LI>HTML text, Internet Recipient</LI> <LI>HTML text, Local Recipient</LI></UL> <P>Now by default the "HTML text, Internet Recipient" is pre-selected for editing when you edit a signature set, but by default, one of the two "Plain text" signature variants is used in an email by default, unless you enable the Rich Text checkbox in an email message or use formatting that automatically enables it.  If you haven't already done so, make sure you've typed a test signature text into all four possible signature "variants" and then try your test.  If signatures are now working, try adding "~!" to all four signature variants and test again to see if the random quote is added to outgoing emails (note that it will not appear on copyself emails, nor does any signature appear in a copyself email).  Use a BCC address to yourself if you want a full copy of exactly what was sent.</P> <P mce_keep="true"> </P>

Please note that each signature "set" contains 4 separate possible signature "variants", one of which will be used based upon the type if email and destination address.  Those four signature variants are:

  • Plain text, Internet Recipient
  • Plain text, Local Recipient
  • HTML text, Internet Recipient
  • HTML text, Local Recipient

Now by default the "HTML text, Internet Recipient" is pre-selected for editing when you edit a signature set, but by default, one of the two "Plain text" signature variants is used in an email by default, unless you enable the Rich Text checkbox in an email message or use formatting that automatically enables it.  If you haven't already done so, make sure you've typed a test signature text into all four possible signature "variants" and then try your test.  If signatures are now working, try adding "~!" to all four signature variants and test again to see if the random quote is added to outgoing emails (note that it will not appear on copyself emails, nor does any signature appear in a copyself email).  Use a BCC address to yourself if you want a full copy of exactly what was sent.

 

<P>Please note that each signature "set" contains 4 separate possible signature "variants", one of which will be used based upon the type if email and destination address.  Those four signature variants are:</P> <UL> <LI>Plain text, Internet Recipient</LI> <LI>Plain text, Local Recipient</LI> <LI>HTML text, Internet Recipient</LI> <LI>HTML text, Local Recipient</LI></UL> <P>Now by default the "HTML text, Internet Recipient" is pre-selected for editing when you edit a signature set, but by default, one of the two "Plain text" signature variants is used in an email by default, unless you enable the Rich Text checkbox in an email message or use formatting that automatically enables it.  If you haven't already done so, make sure you've typed a test signature text into all four possible signature "variants" and then try your test.  If signatures are now working, try adding "~!" to all four signature variants and test again to see if the random quote is added to outgoing emails (note that it will not appear on copyself emails, nor does any signature appear in a copyself email).  Use a BCC address to yourself if you want a full copy of exactly what was sent.</P> <P mce_keep="true"> </P>

[quote user="dkocmoud"]

Please note that each signature "set" contains 4 separate possible signature "variants", one of which will be used based upon the type if email and destination address.  Those four signature variants are:

  • Plain text, Internet Recipient
  • Plain text, Local Recipient
  • HTML text, Internet Recipient
  • HTML text, Local Recipient

Now by default the "HTML text, Internet Recipient" is pre-selected for editing when you edit a signature set, but by default, one of the two "Plain text" signature variants is used in an email by default, unless you enable the Rich Text checkbox in an email message or use formatting that automatically enables it.  If you haven't already done so, make sure you've typed a test signature text into all four possible signature "variants" and then try your test.  If signatures are now working, try adding "~!" to all four signature variants and test again to see if the random quote is added to outgoing emails (note that it will not appear on copyself emails, nor does any signature appear in a copyself email).  Use a BCC address to yourself if you want a full copy of exactly what was sent.

[/quote]

Well, it's working but not as you describe.  It depends on which signature I have selected under the tools-options- default signature as to which sig is used in the email.  The taglines from Plato are working but it must be selected in the default section.  Selecting a signature in the message window does nothing.  I haven't used Pmail for awhile and I don't really remember the finer points but I thought the user could select a specific signature for each message in the message window.   Additionally, any signature selected in the default section is immediately added to the message as soon as the message window is brought up.  You must type your message above the sig and then send it.  No signature is ever added to the message during the send function.

[quote user="dkocmoud"] <P>Please note that each signature "set" contains 4 separate possible signature "variants", one of which will be used based upon the type if email and destination address.  Those four signature variants are:</P> <UL> <LI>Plain text, Internet Recipient</LI> <LI>Plain text, Local Recipient</LI> <LI>HTML text, Internet Recipient</LI> <LI>HTML text, Local Recipient</LI></UL> <P>Now by default the "HTML text, Internet Recipient" is pre-selected for editing when you edit a signature set, but by default, one of the two "Plain text" signature variants is used in an email by default, unless you enable the Rich Text checkbox in an email message or use formatting that automatically enables it.  If you haven't already done so, make sure you've typed a test signature text into all four possible signature "variants" and then try your test.  If signatures are now working, try adding "~!" to all four signature variants and test again to see if the random quote is added to outgoing emails (note that it will not appear on copyself emails, nor does any signature appear in a copyself email).  Use a BCC address to yourself if you want a full copy of exactly what was sent.</P> <P>[/quote]</P> <P>Well, it's working but not as you describe.  It depends on which signature I have selected under the tools-options- default signature as to which sig is used in the email.  The taglines from Plato are working but it must be selected in the default section.  Selecting a signature in the message window does nothing.  I haven't used Pmail for awhile and I don't really remember the finer points but I thought the user could select a specific signature for each message in the message window.   Additionally, any signature selected in the default section is immediately added to the message as soon as the message window is brought up.  You must type your message above the sig and then send it.  No signature is ever added to the message during the send function.</P>

In Pegaus Mail, you can define up to 9 different signature "sets", from which you can choose the default signature set on a per-Identity basis (each user can have multiple Identities, a topic which is out of the scope of this document).  Within a signature set, there are the 4 signature "variants" that I talked about above; you don't get to chose which of these 4 are used because it is done automatically based upon the type of email message you send (HTML Rich Text or Plain Text) as well as whether the recipient is local (only applies to NetWare and multi-user standalone configurations) or external (i.e. Internet).  All you get to select is which signature set is the default set.

Now having said that, a fairly new option added to Pegasus Mail now allows you to tell Pegasus Mail to immediately paste the default signature into a message at the time that the message is created rather than at the time of sending it.  Note that Pegasus Mail cannot possibly know which signature variant to use at this point because the email format type and recipients are not set in stone until you actually click Send.  So, that option also prompts you for the signature variant to use from the default signature, which might not always match up well, but that's life.

Anyway, if you disable the option in the Signatures section to "add this variant of the default signature upon message creation", then you can select the signature set within a message properly and it will be used at the time that you send the email.

<P>In Pegaus Mail, you can define up to 9 different signature "sets", from which you can choose the default signature set on a per-Identity basis (each user can have multiple Identities, a topic which is out of the scope of this document).  Within a signature set, there are the 4 signature "variants" that I talked about above; you don't get to chose which of these 4 are used because it is done automatically based upon the type of email message you send (HTML Rich Text or Plain Text) as well as whether the recipient is local (only applies to NetWare and multi-user standalone configurations) or external (i.e. Internet).  All you get to select is which signature set is the default set.</P> <P>Now having said that, a fairly new option added to Pegasus Mail now allows you to tell Pegasus Mail to immediately paste the default signature into a message at the time that the message is created rather than at the time of sending it.  Note that Pegasus Mail cannot possibly know which signature variant to use at this point because the email format type and recipients are not set in stone until you actually click Send.  So, that option also prompts you for the signature variant to use from the default signature, which might not always match up well, but that's life. </P> <P>Anyway, if you disable the option in the Signatures section to "add this variant of the default signature upon message creation", then you can select the signature set within a message properly and it will be used at the time that you send the email.</P>

In Pegaus Mail, you can define up to 9 different signature "sets", from which you can choose the default signature set on a per-Identity basis (each user can have multiple Identities, a topic which is out of the scope of this document).  Within a signature set, there are the 4 signature "variants" that I talked about above; you don't get to chose which of these 4 are used because it is done automatically based upon the type of email message you send (HTML Rich Text or Plain Text) as well as whether the recipient is local (only applies to NetWare and multi-user standalone configurations) or external (i.e. Internet).  All you get to select is which signature set is the default set.

Now having said that, a fairly new option added to Pegasus Mail now allows you to tell Pegasus Mail to immediately paste the default signature into a message at the time that the message is created rather than at the time of sending it.  Note that Pegasus Mail cannot possibly know which signature variant to use at this point because the email format type and recipients are not set in stone until you actually click Send.  So, that option also prompts you for the signature variant to use from the default signature, which might not always match up well, but that's life.

Anyway, if you disable the option in the Signatures section to "add this variant of the default signature upon message creation", then you can select the signature set within a message properly and it will be used at the time that you send the email.

<P>In Pegaus Mail, you can define up to 9 different signature "sets", from which you can choose the default signature set on a per-Identity basis (each user can have multiple Identities, a topic which is out of the scope of this document).  Within a signature set, there are the 4 signature "variants" that I talked about above; you don't get to chose which of these 4 are used because it is done automatically based upon the type of email message you send (HTML Rich Text or Plain Text) as well as whether the recipient is local (only applies to NetWare and multi-user standalone configurations) or external (i.e. Internet).  All you get to select is which signature set is the default set.</P> <P>Now having said that, a fairly new option added to Pegasus Mail now allows you to tell Pegasus Mail to immediately paste the default signature into a message at the time that the message is created rather than at the time of sending it.  Note that Pegasus Mail cannot possibly know which signature variant to use at this point because the email format type and recipients are not set in stone until you actually click Send.  So, that option also prompts you for the signature variant to use from the default signature, which might not always match up well, but that's life. </P> <P>Anyway, if you disable the option in the Signatures section to "add this variant of the default signature upon message creation", then you can select the signature set within a message properly and it will be used at the time that you send the email.</P>

[quote user="dkocmoud"]

Anyway, if you disable the option in the Signatures section to "add this variant of the default signature upon message creation", then you can select the signature set within a message properly and it will be used at the time that you send the email.

[/quote]

 

Thanks, all is understood.  Of course the reason for all this is because I missed that silly little checkbox at the bottom of the sig setup. UGH!

I was in the middle of quite a lenghty response concerning the rquotes.r file generated by Plato but the forum website decided to boot me out before I was finished and put me back into the reply after deleting everything I had written.  Totally frustrated now, I have decided that my question is not important enough.  Guess I'll type the long ones in notepad and paste them in here from now on.

Thanks for all your help sir and have a fine Pegasus day.

 

 

[quote user="dkocmoud"] <P>Anyway, if you disable the option in the Signatures section to "add this variant of the default signature upon message creation", then you can select the signature set within a message properly and it will be used at the time that you send the email.</P> <P>[/quote]</P> <P mce_keep="true"> </P> <P>Thanks, all is understood.  Of course the reason for all this is because I missed that silly little checkbox at the bottom of the sig setup. UGH!</P> <P>I was in the middle of quite a lenghty response concerning the rquotes.r file generated by Plato but the forum website decided to boot me out before I was finished and put me back into the reply after deleting everything I had written.  Totally frustrated now, I have decided that my question is not important enough.  Guess I'll type the long ones in notepad and paste them in here from now on.</P> <P>Thanks for all your help sir and have a fine Pegasus day.</P> <P mce_keep="true"> </P> <P mce_keep="true"> </P>

Well, to make a long question short.  Is there anyway to force the linewrap in multiline quotes to wrap where I want them to?  Plato does a fine job wrapping them all at the line length specified in the import setup but that is not always desirable.  I have tried to edit the rquotes.r file that Plato generates by rearranging the \n", delimiters at the end of the line but that doesn't seem to help.  Also tried eliminating the spaces between the lines of the .lsq file which makes things even worse by simply stripping the first line from a 4 line quote and pasting that into the message. 

I guess I am getting into this too deeply.

<P>Well, to make a long question short.  Is there anyway to force the linewrap in multiline quotes to wrap where I want them to?  Plato does a fine job wrapping them all at the line length specified in the import setup but that is not always desirable.  I have tried to edit the rquotes.r file that Plato generates by rearranging the \n", delimiters at the end of the line but that doesn't seem to help.  Also tried eliminating the spaces between the lines of the .lsq file which makes things even worse by simply stripping the first line from a 4 line quote and pasting that into the message.  </P> <P>I guess I am getting into this too deeply.</P>

I haven't personally used Plato, but it sounds like it's generating the standard RQUOTES.R file expected by the (now ancient) rescom resource compiler. If so, then you need to terminate each line in the source file with a \n sequence. For arcane reasons, it's not enough just to shift the \n around in the line (so, you can't have text following it on the line) - you actually have to end the line with \n and move the excess text to the start of the next line. Note also that the \n must appear INSIDE the quoted string.

Hope this helps.

-- David --

 

<p>I haven't personally used Plato, but it sounds like it's generating the standard RQUOTES.R file expected by the (now ancient) rescom resource compiler. If so, then you need to terminate each line in the source file with a \n sequence. For arcane reasons, it's not enough just to shift the \n around in the line (so, you can't have text following it on the line) - you actually have to end the line with \n and move the excess text to the start of the next line. Note also that the \n must appear INSIDE the quoted string. Hope this helps. -- David --  </p>

[quote user="David Harris"]

I haven't personally used Plato, but it sounds like it's generating the standard RQUOTES.R file expected by the (now ancient) rescom resource compiler. If so, then you need to terminate each line in the source file with a \n sequence. For arcane reasons, it's not enough just to shift the \n around in the line (so, you can't have text following it on the line) - you actually have to end the line with \n and move the excess text to the start of the next line. Note also that the \n must appear INSIDE the quoted string.

Hope this helps.

-- David --

[/quote]

Yessir, yessir, been there , done that, got the T-shirt.  rquotes.r is indeed the file that Plato is generating.  It also generates a filename.lsq file which I have no idea of it purpose in life.  It appears to be a copy of the rquotes file without the formatting characters.

I have rearranged the formatting as you describe but it has no affect. 

 text x
   {
   "xxxxxxxxxxxxxxxxxxxxx \n",
   "yyyyyyyy \n", 

};,

Simply causes Plato to add the line xxxxxxxxxxxxxxxxxxxxx, or yyyyyyyy.  Never both.  One would think that the {    }', signs would mark the beginning and end of the quote.  Nope, dunno how the dern thing is working.  The formatting works if the file is compiled by Plato at the specified line length but I have not found a way to edit it and force the linefeed.  Editing the .lsq file is equally futile.

 

[quote user="David Harris"] <P>I haven't personally used Plato, but it sounds like it's generating the standard RQUOTES.R file expected by the (now ancient) rescom resource compiler. If so, then you need to terminate each line in the source file with a \n sequence. For arcane reasons, it's not enough just to shift the \n around in the line (so, you can't have text following it on the line) - you actually have to end the line with \n and move the excess text to the start of the next line. Note also that the \n must appear INSIDE the quoted string. Hope this helps. -- David --</P> <P>[/quote]</P> <P>Yessir, yessir, been there , done that, got the T-shirt.  rquotes.r is indeed the file that Plato is generating.  It also generates a filename.lsq file which I have no idea of it purpose in life.  It appears to be a copy of the rquotes file without the formatting characters.</P> <P>I have rearranged the formatting as you describe but it has no affect.  </P> <P> text x    {    "xxxxxxxxxxxxxxxxxxxxx \n",    "yyyyyyyy \n", </P> <P>};,</P> <P>Simply causes Plato to add the line xxxxxxxxxxxxxxxxxxxxx, or yyyyyyyy.  Never both.  One would think that the {    }', signs would mark the beginning and end of the quote.  Nope, dunno how the dern thing is working.  The formatting works if the file is compiled by Plato at the specified line length but I have not found a way to edit it and force the linefeed.  Editing the .lsq file is equally futile.</P> <P mce_keep="true"> </P>

Well, since this thread is so long I am compelled to post the solution to this, just in case someone else out there is interested.

You cannot go into the rquotes.r file and edit it directly.  In order to get mulitple line quotes to work you must make a seperate text file for each quote linewrapped according to your desires and import it.  The single line quotes may go in one file but the multiliners must each be saved separately with the proper linefeeds.  Once you have all the files imported and listed in the Plato console you can then use the edit function to go into each multiline file.  You will see the quote displayed with two linefeeds between each line.  Close them up so there are no empty linefeeds between the lines and save it.  You can then compile all the files together and the resulting rquotes.r file will be formatted correctly. 

I am sure everyone is thrilled that this mystery of such great significance has finally been solved.

Adios

 

 

<P>Well, since this thread is so long I am compelled to post the solution to this, just in case someone else out there is interested.</P> <P>You cannot go into the rquotes.r file and edit it directly.  In order to get mulitple line quotes to work you must make a seperate text file for each quote linewrapped according to your desires and import it.  The single line quotes may go in one file but the multiliners must each be saved separately with the proper linefeeds.  Once you have all the files imported and listed in the Plato console you can then use the edit function to go into each multiline file.  You will see the quote displayed with two linefeeds between each line.  Close them up so there are no empty linefeeds between the lines and save it.  You can then compile all the files together and the resulting rquotes.r file will be formatted correctly. </P> <P>I am sure everyone is thrilled that this mystery of such great significance has finally been solved.</P> <P>Adios</P> <P mce_keep="true"> </P> <P mce_keep="true"> </P>

Alternatively, you could just not use Plato, and use the rescom resource compiler directly on your source. Rescom definitely respects and preserves your \n characters. Using rescom isn't perhaps quite as pretty as doing it in a nice GUI, but it has worked fine for me for getting on for twenty years.

I think it's probably about time I actually built a GUI for this into the program - Heaven knows it's not very complicated.

Cheers!

-- David --

Alternatively, you could just not use Plato, and use the rescom resource compiler directly on your source. Rescom definitely respects and preserves your \n characters. Using rescom isn't perhaps quite as pretty as doing it in a nice GUI, but it has worked fine for me for getting on for twenty years. I think it's probably about time I actually built a GUI for this into the program - Heaven knows it's not very complicated. Cheers! -- David --
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft