Community Discussions and Support
Korean charset

[quote user="VER"]I wouldn't mind to have the switch the other way around (so use ctrl+shift+p for plain text), or the option "always print html" or something. [/quote]

You can be sure other (many) users would mind, so it's not an option to change Pegasus Mail' default behaviour for plain text. I've now added an option which allows you to set IERenderer as the default printing handler for HTML messages without modifying the default for plain text messages, I could provide a test version for you.

[quote user="idw"]Would selecting UTF-8 as your default charset on Tools => Options => Advanced settings help?[/quote]

[quote user="VER"]No that did not help, I changed the setting, and also tried after restarting Pegasus.[/quote]

It appeared to work here with plain text messages at least, can you forward one of your "problem" messages to me (IERenderer's About dialog provides a contact link)?

[quote user="irelam"]For the Charset to be used, I would suggest EUC-KR instead.[/quote]

[quote user="VER"]I cannot find this one in the options?[/quote]

Just type it in, Pegasus Mail can handle a lot more charsets than listed, for a (still incomplete) overview see the LibIconv homepage.

<p>[quote user="VER"]I wouldn't mind to have the switch the other way around (so use ctrl+shift+p for plain text), or the option "always print html" or something. [/quote]</p><p>You can be sure other (many) users would mind, so it's not an option to change Pegasus Mail' default behaviour for plain text. I've now added an option which allows you to set IERenderer as the default printing handler for HTML messages without modifying the default for plain text messages, I could provide a test version for you.</p><p>[quote user="idw"]Would selecting UTF-8 as your default charset on <i>Tools => Options => Advanced settings</i> help?[/quote]</p><p>[quote user="VER"]No that did not help, I changed the setting, and also tried after restarting Pegasus.[/quote]</p><p>It appeared to work here with plain text messages at least, can you forward one of your "problem" messages to me (IERenderer's <em>About</em> dialog provides a contact link)?</p><p>[quote user="irelam"]For the Charset to be used, I would suggest EUC-KR instead.[/quote]</p><p>[quote user="VER"]I cannot find this one in the options?[/quote]</p><p>Just type it in, Pegasus Mail can handle a lot more charsets than listed, for a (still incomplete) overview see the <a href="http://www.gnu.org/software/libiconv/" mce_href="http://www.gnu.org/software/libiconv/">LibIconv homepage</a>.</p>

			Michael

--
PGP Key ID (RSA 2048): 0xC45D831B
IERenderer's Home: https://www.pmpgp.de/renderer/History.htm
S/MIME Fingerprint: 94C6B471 0C623088 A5B27701 742B8666 3B7E657C

Hi All,

First of all I'd like to thank all of you for version 4.61. Especially the html renderer has been a life safer!

Now back on subject:

I received a HTML mail with the following charset: "ks_c_5601-1987"

This e-mail displays correctly. Printing goes also OK when using ctrl+shift+p.

Forwarding and replying leads to a bunch of (for us) unreadable characters. I know the use of bouncing (which is very usable, but sometimes you need to add some explanation. Also replying with preserve original HTML does not work.


I have the following questions:

1> Would it be possible to enforce the ctrl+shift+p printing by default (as my users have difficulties in remembering this)? (IErenderer is set to be used, I thought this would also enforce ctrl+shift+p?)

2> Is there any possibility to have the forwarding and replying include the correct characterset so that they display correctly?

I've succesfully changed the charset in the *.cnm in the past, this is however not the preferred solution.

 

Thanks for your assistance!

AM

 

 

<p>Hi All,</p><p>First of all I'd like to thank all of you for version 4.61. Especially the html renderer has been a life safer!</p><p>Now back on subject:</p><p>I received a HTML mail with the following charset: "ks_c_5601-1987"</p><p>This e-mail displays correctly. Printing goes also OK when using ctrl+shift+p.</p><p>Forwarding and replying leads to a bunch of (for us) unreadable characters. I know the use of bouncing (which is very usable, but sometimes you need to add some explanation. Also replying with preserve original HTML does not work. </p><p> I have the following questions:</p><p>1> Would it be possible to enforce the ctrl+shift+p printing by default (as my users have difficulties in remembering this)? (IErenderer is set to be used, I thought this would also enforce ctrl+shift+p?)</p><p>2> Is there any possibility to have the forwarding and replying include the correct characterset so that they display correctly?</p><p>I've succesfully changed the charset in the *.cnm in the past, this is however not the preferred solution.</p><p> </p><p>Thanks for your assistance!</p><p>AM </p><p> </p><p> </p>

[quote user="VER"]First of all I'd like to thank all of you for version 4.61. Especially the html renderer has been a life safer![/quote]

Thanks.

[quote user="VER"]Forwarding and replying leads to a bunch of (for us) unreadable characters. I know the use of bouncing (which is very usable, but sometimes you need to add some explanation. Also replying with preserve original HTML does not work.[/quote]

Forwarding as attachment would probably work and allow you to include your comments, for replying I don't know what to suggest, I guess that highlighting all text and choosing the selected text option on replying doesn't help either?

[quote user="VER"]1> Would it be possible to enforce the ctrl+shift+p printing by default (as my users have difficulties in remembering this)? (IErenderer is set to be used, I thought this would also enforce ctrl+shift+p?)[/quote]

I could implement this, maybe I'll add another option for it, but did you note the toolbar button created by (and for) IERenderer? It open's a menu containing an entry for printing HTML messages which also displays the proper shortcut ...

[quote user="VER"]2> Is there any possibility to have the forwarding and replying include the correct characterset so that they display correctly?[/quote]

Would selecting UTF-8 as your default charset on Tools => Options => Advanced settings help?

<p>[quote user="VER"]First of all I'd like to thank all of you for version 4.61. Especially the html renderer has been a life safer![/quote]</p><p>Thanks.</p><p>[quote user="VER"]Forwarding and replying leads to a bunch of (for us) unreadable characters. I know the use of bouncing (which is very usable, but sometimes you need to add some explanation. Also replying with preserve original HTML does not work.[/quote]</p><p>Forwarding as attachment would probably work and allow you to include your comments, for replying I don't know what to suggest, I guess that highlighting all text and choosing the selected text option on replying doesn't help either?</p><p>[quote user="VER"]1> Would it be possible to enforce the ctrl+shift+p printing by default (as my users have difficulties in remembering this)? (IErenderer is set to be used, I thought this would also enforce ctrl+shift+p?)[/quote]</p><p>I could implement this, maybe I'll add another option for it, but did you note the toolbar button created by (and for) IERenderer? It open's a menu containing an entry for printing HTML messages which also displays the proper shortcut ...</p><p>[quote user="VER"]2> Is there any possibility to have the forwarding and replying include the correct characterset so that they display correctly?[/quote]</p><p>Would selecting UTF-8 as your default charset on <em>Tools => Options => Advanced settings</em> help?</p>

			Michael

--
PGP Key ID (RSA 2048): 0xC45D831B
IERenderer's Home: https://www.pmpgp.de/renderer/History.htm
S/MIME Fingerprint: 94C6B471 0C623088 A5B27701 742B8666 3B7E657C

For the Charset to be used, I would suggest EUC-KR instead.

Martin

<p>For the Charset to be used, I would suggest EUC-KR instead.</p><p>Martin </p>

[quote user="idw"][quote user="VER"]Forwarding and replying leads to a bunch of (for us) unreadable characters. I know the use of bouncing (which is very usable, but sometimes you need to add some explanation. Also replying with preserve original HTML does not work.[/quote]

Forwarding as attachment would probably work and allow you to include your comments, for replying I don't know what to suggest, I guess that highlighting all text and choosing the selected text option on replying doesn't help either? [/quote]

Forgot about the selected text option, that one works. Thx. This can (with some editing) also be used for forwarding, the workaround has been found!
I would expect however that such an e-mail would remain intact when using the preserve original HTML reply-option?

[quote user="idw"] [quote user="VER"]1> Would it be possible to enforce the ctrl+shift+p printing by default (as my users have difficulties in remembering this)? (IErenderer is set to be used, I thought this would also enforce ctrl+shift+p?)[/quote]

I could implement this, maybe I'll add another option for it, but did you note the toolbar button created by (and for) IERenderer? It open's a menu containing an entry for printing HTML messages which also displays the proper shortcut ... [/quote]

Yeah.... I did [:P], I'm not the problem here though... I can explain this a dozen time without result...
I wouldn't mind to have the switch the other way around (so use ctrl+shift+p for plain text), or the option "always print html" or something.

[quote user="idw"][quote user="VER"]2> Is there any possibility to have the forwarding and replying include the correct characterset so that they display correctly?[/quote]

Would selecting UTF-8 as your default charset on Tools => Options => Advanced settings help?[/quote]
No that did not help, I changed the setting, and also tried after restarting Pegasus.

[quote user="irelam"]For the Charset to be used, I would suggest EUC-KR instead.[/quote]
I cannot find this one in the options?

AM

<p>[quote user="idw"][quote user="VER"]Forwarding and replying leads to a bunch of (for us) unreadable characters. I know the use of bouncing (which is very usable, but sometimes you need to add some explanation. Also replying with preserve original HTML does not work.[/quote]</p> <p>Forwarding as attachment would probably work and allow you to include your comments, for replying I don't know what to suggest, I guess that highlighting all text and choosing the selected text option on replying doesn't help either? [/quote] </p> <p>Forgot about the selected text option, that one works. Thx. This can (with some editing) also be used for forwarding, the workaround has been found! I would expect however that such an e-mail would remain intact when using the preserve original HTML reply-option? </p> <p>[quote user="idw"] [quote user="VER"]1> Would it be possible to enforce the ctrl+shift+p printing by default (as my users have difficulties in remembering this)? (IErenderer is set to be used, I thought this would also enforce ctrl+shift+p?)[/quote]</p> <p>I could implement this, maybe I'll add another option for it, but did you note the toolbar button created by (and for) IERenderer? It open's a menu containing an entry for printing HTML messages which also displays the proper shortcut ... [/quote]</p> <p>Yeah.... I did [:P], I'm not the problem here though... I can explain this a dozen time without result... I wouldn't mind to have the switch the other way around (so use ctrl+shift+p for plain text), or the option "always print html" or something. </p> <p>[quote user="idw"][quote user="VER"]2> Is there any possibility to have the forwarding and replying include the correct characterset so that they display correctly?[/quote]</p> <p>Would selecting UTF-8 as your default charset on <i>Tools => Options => Advanced settings</i> help?[/quote] No that did not help, I changed the setting, and also tried after restarting Pegasus.</p> <p>[quote user="irelam"]For the Charset to be used, I would suggest EUC-KR instead.[/quote] I cannot find this one in the options?</p><p>AM </p>
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft