Extension development
BearHTML - ancient image download/display bug - triggered by POP3 download

That was IT! Changing Load Windows Internet Services set to Always takes care of it. Perfect! [:D]

Thanks a lot, Michael!

George

<p>That was IT! Changing <em>Load Windows Internet Services</em> set to <em>Always </em>takes care of it. Perfect! [:D] </p><p>Thanks a lot, Michael!</p><p>George </p>

This one has been bugging me for years: BearHTML stops downloading images after *any* POP3 download. (FYI, my Pmail is set to "display remote images manually".)

Steps to reproduce:

- start Pmail

- click to download your emails via POP3

- open *any* HTML message (for which you have not downloaded images yet), and bring up the context-menu

- click "Show pictures (HTML only)"

What happens: the Pmail statusbar shows the process of enumerating images to download - but everything happens in a flash, and no image gets actually downloaded.

Opening *any* other HTML message and trying to display pictures results in the same failure. Pmail acts like doing it - but it does not download anything.

To get Pmail to download images for HTML messages again it is necessary to *restart* Pmail. Image downloading will work after restart, right until the first POP3 download, after which images will fail to download again.

Hint: shockingly for me, the short-lived version 4.6.9.0 - to which I have no longer access - did *not* exhibit this problem, when I tried it before Christmas. One would think, the two problems, broken CSS-support, and problem with image downloads may well be related.

George

<p>This one has been bugging me for years: BearHTML stops downloading images after *any* POP3 download. (FYI, my Pmail is set to "display remote images manually".) </p><p>Steps to reproduce:</p><p>- start Pmail </p><p>- click to download your emails via POP3</p><p>- open *any* HTML message (for which you have not downloaded images yet), and bring up the context-menu</p><p>- click "Show pictures (HTML only)"</p><p>What happens: the Pmail statusbar shows the process of enumerating images to download - but everything happens in a flash, and no image gets actually downloaded.</p><p>Opening *any* other HTML message and trying to display pictures results in the same failure. Pmail acts like doing it - but it does not download anything.</p><p>To get Pmail to download images for HTML messages again it is necessary to *restart* Pmail. Image downloading will work after restart, right until the first POP3 download, after which images will fail to download again.</p><p>Hint: shockingly for me, the short-lived version 4.6.9.0 - to which I have no longer access - did *not* exhibit this problem, when I tried it before Christmas. One would think, the two problems, broken CSS-support, and problem with image downloads may well be related. </p><p>George </p>

[quote user="Geo"]This one has been bugging me for years: BearHTML stops downloading images after *any* POP3 download. (FYI, my Pmail is set to "display remote images manually".) [/quote]

Do you have Tools => Options => Advanced settings => Load Windows Internet Services set to Always (restart after changing)?

<p>[quote user="Geo"]This one has been bugging me for years: BearHTML stops downloading images after *any* POP3 download. (FYI, my Pmail is set to "display remote images manually".) [/quote]</p><p>Do you have <em>Tools => Options => Advanced settings => Load Windows Internet Services</em> set to <em>Always</em> (restart after changing)?</p>

			Michael

--
PGP Key ID (RSA 2048): 0xC45D831B
PGP Plugin for Pegasus Mail: <https:></https:>
S/MIME Fingerprint: 94C6B471 0C623088 A5B27701 742B8666 3B7E657C

If you trigger a manual download of images for a message, you must wait until they have completed the download process, before moving on to any other message.

Martin 

&lt;p&gt;If you trigger a manual download of images for a message, you must wait until they have completed the download process, before moving on to any other message.&lt;/p&gt;&lt;p&gt;Martin&amp;nbsp;&lt;/p&gt;

Martin,

The mouse cursor clearly indicates process state/completion, it is not even possible to move on to another message before downloads are finished (in classic, non-multi-panel mailbox view).

This is not a cursory observation, I have been living with this annoyance for years. The bug is 100% reproducible, I hope to have given enough details in my description.

BTW, OS is Windows 7 32-bit, running Pmail 4.63, with BearHTML 4.6.8.2 / 4.6.8.16 / 4.6.9.1.

Please, let me know if you need more information, or how I can be of help to get this fixed.

Thank you.

George


&lt;p&gt;Martin,&lt;/p&gt;&lt;p&gt;The mouse cursor clearly indicates process state/completion, it is not even possible to move on to another message before downloads are finished (in classic, non-multi-panel mailbox view). &lt;/p&gt;&lt;p&gt;This is not a cursory observation, I have been living with this annoyance for years. The bug is 100% reproducible, I hope to have given enough details in my description.&lt;/p&gt;&lt;p&gt;BTW, OS is Windows 7 32-bit, running Pmail 4.63, with BearHTML 4.6.8.2 / 4.6.8.16 / 4.6.9.1. &lt;/p&gt;&lt;p&gt;Please, let me know if you need more information, or how I can be of help to get this fixed. &lt;/p&gt;&lt;p&gt;Thank you.&lt;/p&gt;&lt;p&gt;George &lt;/p&gt;&lt;p&gt; &lt;/p&gt;
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft