International Pegasus Mail
Displaying Messages sent from Korea (Simple Workaround)

[quote user="kaihora"]The version of PegasusMail is 4.41 (32bit) on WindowsXP SP2[/quote]

First of all update to the latest version: Language support has been enhanced a lot since version 4.41.

<p>[quote user="kaihora"]The version of PegasusMail is 4.41 (32bit) on WindowsXP SP2[/quote]</p><p>First of all update to the latest version: Language support has been enhanced a lot since version 4.41.</p>

			Michael

--
PGP Key ID (RSA 2048): 0xC45D831B
IERenderer's Home: https://www.pmpgp.de/renderer/History.htm
S/MIME Fingerprint: 94C6B471 0C623088 A5B27701 742B8666 3B7E657C

I find when I receive messages from a Korean correspondent I encounter problems using Pegaus 4.41:

1. Sometimes the sender and subject fields are not displayed properly in the folder view. Sometimes it is blank while other times a series of black squares is displayed. Sometimes I will get black squares in the new mail folder and the proper text will get displayed after I move it into a another folder. But sometimes I can't see the text there either.

2. When I hit reply and Pegasus copies the original text into the reply quoted with a "> " either there is nothing copied or I get a bunch of Chinese looking characters (not Korean) copied into the message. I have to manually copy the text from the original message and use the Paste Special function to get it copied into my reply as quoted text.

The messages are in English, but this seems to be a common problem that I have when corresponding  with Koreans. One of my regular correspondents uses webmail from empal.com but I also have these issues with other Korean correspondents. 

I am wondering if this is a bug or perhaps a configuration issue. I don't have this problem with Chinese correspondents.

Here is a partial header from a recent email with "x" replacing the personally identifiable information:

X-Auth-No:
Return-Path: <xxxxxxxxxxxx@empal.com>
Received: from tx9.empal.com not authenticated [61.97.70.219]
by xxxxxxxxx.com with NetMail SMTP Agent $Revision: 6820 $ on Novell NetWare;
Wed, 12 Sep 2007 00:39:31 -0400
Received: from external ([10.151.12.133])
by xptx9.empal.com (1.0) id l8C4dIw0076D;
Wed, 12 Sep 2007 13:39:18 +0900
X-SMF-UNIQ9B3F5470AEACB4007E467A39F5241948: l8C4dIw0076D
X-SMF-MAILFROMl8C4dIw0076D: xxxxxxxxxxxx@empal.com
Message-ID: <xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx@empal.com>
From: =?ks_c_5601-1987?B?xxxxxxxxxxxxxxxxxxxxxxxxx
To: =?ks_c_5601-1987?B?xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Subject: =?ks_c_5601-1987?B?xxxxxxxxxxxxxxxxxxxxxxxxxxx
Date: Wed, 12 Sep 2007 13:39:18 +0900
MIME-Version: 1.0
Content-Type: text/html; charset="ks_c_5601-1987"
Content-Transfer-Encoding: base64
X-Priority: 3
X-Mailer: empal MIME interface v2.1
X-PMFLAGS: 34099904 0 1 P692C1LR.CNM
&lt;P&gt;I find when I receive messages from a&amp;nbsp;Korean correspondent I encounter problems using Pegaus 4.41:&lt;/P&gt; &lt;P&gt;1. Sometimes the sender and subject fields are not displayed properly in the folder view. Sometimes it is blank while other times a series of black squares is displayed. Sometimes I will get black squares in the new mail folder and the proper text will get displayed after I move it into a another folder. But sometimes I can&#039;t see the text there either.&lt;/P&gt; &lt;P&gt;2. When I hit reply and Pegasus copies the original text into the reply quoted with a &quot;&amp;gt; &quot; either there is nothing copied or I get a bunch of Chinese looking characters (not Korean) copied into the message. I have to manually copy the text from the original message and use the Paste Special function to get it copied into my reply as quoted text.&lt;/P&gt; &lt;P&gt;The messages are in English, but this seems to be a common problem that I have when corresponding &amp;nbsp;with Koreans.&amp;nbsp;One of my regular&amp;nbsp;correspondents uses webmail from empal.com but&amp;nbsp;I also have these issues with other Korean correspondents.&amp;nbsp;&lt;/P&gt; &lt;P&gt;I am wondering if this is a bug or perhaps a configuration issue. I don&#039;t have this problem with Chinese correspondents.&lt;/P&gt; &lt;P&gt;Here is a partial header from a recent email with &quot;x&quot; replacing the personally identifiable information:&lt;/P&gt;&lt;FONT face=Courier size=3&gt;X-Auth-No: Return-Path: &amp;lt;&lt;A href=&quot;mailto:xxxxxxxxxxxx@empal.com&quot;&gt;xxxxxxxxxxxx@empal.com&lt;/A&gt;&amp;gt; Received: from tx9.empal.com not authenticated [61.97.70.219] by xxxxxxxxx.com with NetMail SMTP Agent $Revision: 6820 $ on Novell NetWare; Wed, 12 Sep 2007 00:39:31 -0400 Received: from external ([10.151.12.133]) by xptx9.empal.com (1.0) id l8C4dIw0076D; Wed, 12 Sep 2007 13:39:18 +0900 X-SMF-UNIQ9B3F5470AEACB4007E467A39F5241948: l8C4dIw0076D X-SMF-MAILFROMl8C4dIw0076D: &lt;A href=&quot;mailto:xxxxxxxxxxxx@empal.com&quot;&gt;xxxxxxxxxxxx@empal.com&lt;/A&gt; Message-ID: &amp;lt;&lt;A href=&quot;mailto:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx@empal.com&quot;&gt;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx@empal.com&lt;/A&gt;&amp;gt; From: =?ks_c_5601-1987?B?xxxxxxxxxxxxxxxxxxxxxxxxx To: =?ks_c_5601-1987?B?xxxxxxxxxxxxxxxxxxxxxxxxxxxxx Subject: =?ks_c_5601-1987?B?xxxxxxxxxxxxxxxxxxxxxxxxxxx Date: Wed, 12 Sep 2007 13:39:18 +0900 MIME-Version: 1.0 Content-Type: text/html; charset=&quot;ks_c_5601-1987&quot; Content-Transfer-Encoding: base64 X-Priority: 3 X-Mailer: empal MIME interface v2.1 X-PMFLAGS: 34099904 0 1 P692C1LR.CNM &lt;/FONT&gt;

Make sure you have Korean fonts installed on the machine - Pegasus Mail actually recognizes the odd Korean character set in the headers (most mail programs do not) and tries to render it accordingly: as a result, if you don't have the necessary fonts installed, you'll get boxes or blanks displayed.

Another thing is to make sure that the Korean character strings are actually valid and map correctly onto the proper unicode characters.

It's very difficult for me to test this type of thing during development, so I'm not going to say hard and fast that there's no problem in the program handling this type of data, but certainly most of the reports I've seen so far suggest that on a properly-configured system, the program should handle Korean characters correctly.

Cheers!

-- David --

Make sure you have Korean fonts installed on the machine - Pegasus Mail actually recognizes the odd Korean character set in the headers (most mail programs do not) and tries to render it accordingly: as a result, if you don&#039;t have the necessary fonts installed, you&#039;ll get boxes or blanks displayed. Another thing is to make sure that the Korean character strings are actually valid and map correctly onto the proper unicode characters. It&#039;s very difficult for me to test this type of thing during development, so I&#039;m not going to say hard and fast that there&#039;s no problem in the program handling this type of data, but certainly most of the reports I&#039;ve seen so far suggest that on a properly-configured system, the program should handle Korean characters correctly. Cheers! -- David --

Just another point... In the sample you sent, the declaration for the message indicates that the character encoding for the message should be the Korean character set. Now, an error I have seen quite often is for the declaration to say "ks_c_5601-1987" but for the message body actually to be in US-ASCII, which is an error in the sending mailer. Ironically, other mail programs that do not recognize the Korean character set will display the message "correctly", because the defined fallback action for a MIME message where the character set is not recognized is to use US-ASCII. As I remarked above though, Pegasus Mail actually DOES know how to handle this character set, so if the body uses the wrong character mapping, you'll get a garbage display, even though Pegasus Mail is following the rules precisely.

If this is the problem, then it can only be fixed by getting the sending mail program repaired - Pegasus Mail is actually behaving correctly based on the information it is being given. You can check this out by manually editing the .CNM file and removing the "Charset" parameter from the Content-type header: if the message displays correctly after this change, then the sender's mail program is broken.

Cheers!

-- David --

Just another point... In the sample you sent, the declaration for the message indicates that the character encoding for the message should be the Korean character set. Now, an error I have seen quite often is for the declaration to say &quot;ks_c_5601-1987&quot; but for the message body actually to be in US-ASCII, which is an error in the sending mailer. Ironically, other mail programs that do not recognize the Korean character set will display the message &quot;correctly&quot;, because the defined fallback action for a MIME message where the character set is not recognized is to use US-ASCII. As I remarked above though, Pegasus Mail actually DOES know how to handle this character set, so if the body uses the wrong character mapping, you&#039;ll get a garbage display, even though Pegasus Mail is following the rules precisely. If this is the problem, then it can only be fixed by getting the sending mail program repaired - Pegasus Mail is actually behaving correctly based on the information it is being given. You can check this out by manually editing the .CNM file and removing the &quot;Charset&quot; parameter from the Content-type header: if the message displays correctly after this change, then the sender&#039;s mail program is broken. Cheers! -- David --

To further support David's response, just check the first line of the message body, using the Raw View you used to supply the headers. If the body contains Western Ascii text it will be viewable. We had a problem recorded on this forum a couple of months ago, where the sender forgot to change their default email charset.  In Pegasus Mail the default charset is selectable in Tools/General Settings/Advanced/Default Mime charset drop down list

 
Martin.

&lt;p&gt;To further support David&#039;s response, just check the first line of the message body, using the Raw View you used to supply the headers. If the body contains Western Ascii text it will be viewable. We had a problem recorded on this forum a couple of months ago, where the sender forgot to change their default email charset.&amp;nbsp; In Pegasus Mail the default charset is selectable in Tools/General Settings/Advanced/Default Mime charset drop down list&lt;/p&gt;&lt;p&gt;&amp;nbsp; Martin. &lt;/p&gt;

1. I have the Korean character set installed on my machine and the default character set that was configured is ISO-8859-1. I have tried it set to US-ASCII but it didn't seem to change this.

2. Pegasus is actually displaying the text in the original message body properly. But the header From and Subject fields in the folder view are typically blank (sometimes a series of black boxes) although I can also typically see the subject line when the message is opened, although there the Korean name in the From field is not displayed. I can also generally see Korean text when it is embedded in the body of the message interspersed with English.

3. The message body itself looks to the unaided eye to be properly formatted unicode. At least it isn't US-ASCII.

Just to review: the problems are related to displaying the headers in the folder view and that the reply is not formatted properly.

I will send you the raw text and a screen shots in a private mail. It would not surprise me if the Korean mailer has a problem except that I have seen this problem in the past with other Korean emails not from this same person and that the messages do seem to display properly on other peoples machines here using Mozilla and Microsoft clients.

Thanks, 

Ralph

&lt;P&gt;1. I have the Korean character set installed on my machine and the default character set that was configured is ISO-8859-1.&amp;nbsp;I have tried it set to US-ASCII but it didn&#039;t seem to change this. &lt;/P&gt; &lt;P&gt;2. Pegasus is actually displaying the text in the original message body properly. But the header From and Subject fields in the folder view&amp;nbsp;are typically blank (sometimes a series of black boxes) although I can also typically see the subject line when the message is opened, although there the Korean name in the From field is not displayed. I can also generally see Korean text when it is embedded in the body of the message interspersed with English.&lt;/P&gt; &lt;P&gt;3. The message body itself looks to the unaided eye to be properly formatted unicode. At least it isn&#039;t US-ASCII.&lt;/P&gt; &lt;P&gt;Just to review: the problems are related to displaying the headers in the folder view and that the reply is not formatted properly.&lt;/P&gt; &lt;P&gt;I will send you the raw text and a screen shots&amp;nbsp;in a private mail. It would not surprise me if the Korean mailer has a problem except that I have seen this problem in the past with other Korean emails not from this same person and that the messages do seem to display properly on other peoples machines here using&amp;nbsp;Mozilla and Microsoft clients.&lt;/P&gt; &lt;P&gt;Thanks,&amp;nbsp;&lt;/P&gt; &lt;P&gt;Ralph&lt;/P&gt;

PLease send me a sample message, and I will confirm the character set problem and possible solution

Martin 

&lt;p&gt;PLease send me a sample message, and I will confirm the character set problem and possible solution&lt;/p&gt;&lt;p&gt;Martin&amp;nbsp;&lt;/p&gt;

Just to confirm I have received your sample message.

Martin 

&lt;p&gt;Just to confirm I have received your sample message. &lt;/p&gt;&lt;p&gt;Martin&amp;nbsp;&lt;/p&gt;

I loaded your message into MS Word, and it responded that the Dotumche font was needed to be installed. I got that from Microsoft site as file IE-KR.EXE which is part of Far East Support.

I then produced the following line in MS Word.  I trust it means something to you.  Meanwhile I have been unable so far to find a near equivalent that we can use in Pegasus Mail. 

 Korean characters in msg

 Regards,

        Martin
 

&lt;p&gt;I loaded your message into MS Word, and it responded that the Dotumche font was needed to be installed. I got that from Microsoft site as file IE-KR.EXE which is part of Far East Support.&lt;/p&gt;&lt;p&gt;I then produced the following line in MS Word.&amp;nbsp; I trust it means something to you.&amp;nbsp; Meanwhile I have been unable so far to find a near equivalent that we can use in Pegasus Mail.&amp;nbsp;&lt;/p&gt;&lt;p&gt;&amp;nbsp;&lt;img src=&quot;http://www3.telus.net/public/irelam/KoreanMsg.jpg&quot; title=&quot;Korean characters in msg&quot; alt=&quot;Korean characters in msg&quot; mce_src=&quot; http://www3.telus.net/public/irelam/KoreanMsg.jpg&quot; height=&quot;36&quot; width=&quot;623&quot;&gt;&lt;/p&gt;&lt;p&gt;&amp;nbsp;Regards,&lt;/p&gt;&lt;p&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; Martin &amp;nbsp; &lt;/p&gt;

If I use Charset=euc-kr I get a different set of characters. Which one is right?

http://www3.telus.net/public/irelam/KoreanMsg2.jpg

 

Martin 

&lt;p&gt;If I use Charset=euc-kr I get a different set of characters. Which one is right?&lt;/p&gt;&lt;p&gt;&lt;img src=&quot;http://www3.telus.net/public/irelam/KoreanMsg2.jpg&quot; mce_src=&quot;http://www3.telus.net/public/irelam/KoreanMsg2.jpg&quot;&gt; http://www3.telus.net/public/irelam/KoreanMsg2.jpg&lt;/p&gt;&lt;p&gt;&amp;nbsp;&lt;/p&gt;&lt;p&gt;Martin&amp;nbsp;&lt;/p&gt;

Thanks for trying guys.

 When I bring up the text I posted to you in Word it looks pretty much just like it looks in Pegasus. The body of the email is displayed properly by Pegagus. It is just the From and Subject fields in the folder view that are not displayed properly, and when Pegasus copies the text into a reply it gets garbled into Chinese looking characgters (not Korean). My computer has the Dotum Che font installed already.

I don't really know where the text above comes from. Neither look right. That text doesn't appear in the message that either Pegasus or Word displays on my Sony Vaio.  I also posted a JPG file of the screen shot that I got when looking at the headers for this message in the folder view in Pegaus that illustrates the problem.

 Ralph

&lt;P&gt;Thanks for trying guys. &lt;/P&gt; &lt;P&gt;&amp;nbsp;When I bring up the text I posted to you in Word it looks pretty much just like it looks in Pegasus. The body of the email is displayed properly by Pegagus. It is just the From and Subject fields in the folder view that are not displayed properly, and when Pegasus copies the text into a reply it gets garbled into Chinese looking characgters (not Korean). My computer has the Dotum Che font installed already.&lt;/P&gt; &lt;P&gt;I&amp;nbsp;don&#039;t really know where the text above comes from. Neither look right. That text doesn&#039;t appear in the message&amp;nbsp;that either Pegasus or Word displays on my Sony Vaio. &amp;nbsp;I also posted a JPG file of the screen shot that I got when looking at the headers for this message in the folder view in Pegaus that illustrates the problem.&lt;/P&gt; &lt;P&gt;&amp;nbsp;Ralph&lt;/P&gt;

Scenario 1: We have a good deal of correspondence with Korean families. Often times, their messages are not displayed properly in Pegasus Mail but if I edit the [Content-Type:] section of the headers to [charset=UTF-8]; all is well.

Scenario 2:

In addition to the Korean messages, I recently received a message from http://www.dhs.gov that had used blat v 2.4 (http://www.blat.net) as the mailer and it had incorrectly encoded the MIME message body section with ISO-8859-1. This caused the character ô to be scattered throughout the message where either a CR or double quotes (") should have been. Again, changing the Content-Type: to charset=UTF-8 in the MIME message body section resolved the problem.

 
My question then - can a global filter setting in Mercury/32 that inserts the header "Content-Type: text/plain; charset=UTF-8" or "Content-Type: charset=UTF-8" be harmful or helpful in the first scenario?

I fully understand the multipart message problem (scenario 2) is not something that can be resolved on my end - not in an automated fashion, anyway. I also unterstand that both scenarios are due to a misconfigured sender (be it client or mass mailer) but I am trying to "fix" the problem so that users aren't assuming that there is some problem on my end.

&lt;p&gt;Scenario 1: We have a good deal of correspondence with Korean families. Often times, their messages are not displayed properly in Pegasus Mail but if I edit the [Content-Type:] section of the headers to [charset=UTF-8]; all is well. &lt;/p&gt;&lt;p&gt;Scenario 2: In addition to the Korean messages, I recently received a message from http://www.dhs.gov that had used blat v 2.4 (http://www.blat.net) as the mailer and it had incorrectly encoded the MIME message body section with ISO-8859-1. This caused the character &ocirc; to be scattered throughout the message where either a CR or double quotes (&quot;) should have been. Again, changing the Content-Type: to charset=UTF-8 in the MIME message body section resolved the problem. &lt;/p&gt;&lt;p&gt;&amp;nbsp; My question then - can a global filter setting in Mercury/32 that inserts the header &quot;Content-Type: text/plain; charset=UTF-8&quot; or &quot;Content-Type: charset=UTF-8&quot; be harmful or helpful in the first scenario? &lt;/p&gt;&lt;p&gt;I fully understand the multipart message problem (scenario 2) is not something that can be resolved on my end - not in an automated fashion, anyway. I also unterstand that both scenarios are due to a misconfigured sender (be it client or mass mailer) but I am trying to &quot;fix&quot; the problem so that users aren&#039;t assuming that there is some problem on my end.&lt;/p&gt;

For those of you encountering problems with ks_c_5601-xxx charsets I can provide a workaround: I've modified and re-compiled the ICONV library used by Pegasus Mail for converting charsets, if any of you want to give it a try I can make it available as a "community download", please let me know!

For those of you encountering problems with ks_c_5601-xxx charsets I can provide a workaround: I&#039;ve modified and re-compiled the ICONV library used by Pegasus Mail for converting charsets, if any of you want to give it a try I can make it available as a &quot;community download&quot;, please let me know&lt;font size=&quot;3&quot; face=&quot;Courier&quot;&gt;! &lt;/font&gt;

			Michael

--
PGP Key ID (RSA 2048): 0xC45D831B
IERenderer's Home: https://www.pmpgp.de/renderer/History.htm
S/MIME Fingerprint: 94C6B471 0C623088 A5B27701 742B8666 3B7E657C

Michael, does this library exist?

I have problems with messages from someone who ocasionally uses charset="ks_c_5601-1987" for latin characters. I can read them via other mailers, or after manually replacing the charset info.  Would this new library help?

 

&lt;P&gt;Michael, does this library exist?&lt;/P&gt; &lt;P&gt;I have problems with messages from someone who ocasionally uses&amp;nbsp;&lt;FONT face=&quot;Trebuchet MS&quot;&gt;charset=&quot;ks_c_5601-1987&quot; for latin characters. I can read them via other mailers, or after manually replacing the charset info.&amp;nbsp; Would this new library help?&lt;/FONT&gt;&lt;/P&gt; &lt;P&gt;&lt;FONT face=&quot;Trebuchet MS&quot;&gt;&amp;nbsp;&lt;/P&gt;&lt;/FONT&gt;

[quote user="PaulW"]

Michael, does this library exist?[/quote]

It's part of Pegasus Mail 4.5, but you can also get it from the download section. If it doesn't help please forward a problematic message (idw.doc [at] t-online.de; preferably as zipped CNM-file from your new mail folder - assuming you know how to get these; forwarded without modifications might get deleted by my spam filters).

[quote user=&quot;PaulW&quot;]&lt;p&gt;Michael, does this library exist?[/quote]&lt;/p&gt;&lt;p&gt;It&#039;s part of Pegasus Mail 4.5, but you can also get it from the &lt;a href=&quot;/files/folders/community_add-ons_for_pegasus_mail/entry18219.aspx&quot; target=&quot;_blank&quot; mce_href=&quot;/files/folders/community_add-ons_for_pegasus_mail/entry18219.aspx&quot;&gt;download section&lt;/a&gt;. If it doesn&#039;t help please forward a problematic message (idw.doc [at] t-online.de; preferably as zipped CNM-file from your new mail folder - assuming you know how to get these; forwarded without modifications might get deleted by my spam filters). &lt;/p&gt;

			Michael

--
PGP Key ID (RSA 2048): 0xC45D831B
IERenderer's Home: https://www.pmpgp.de/renderer/History.htm
S/MIME Fingerprint: 94C6B471 0C623088 A5B27701 742B8666 3B7E657C

Thanks Michael, it didn't help so message now forwarded.

Thanks Michael, it didn&#039;t help so message now forwarded.

Hi,

This works for me (so far)

1. Press CTRL+A to select all text.

2. Press Reply

3. Select "Selected Portion"

4. New message starts with normal English instead of Korean/Chinese.

Regards

 

Basheer

 

&lt;p&gt;Hi,&lt;/p&gt;&lt;p&gt;This works for me (so far)&lt;/p&gt;&lt;p&gt;1. Press CTRL+A to select all text.&lt;/p&gt;&lt;p&gt;2. Press Reply&lt;/p&gt;&lt;p&gt;3. Select &quot;Selected Portion&quot;&lt;/p&gt;&lt;p&gt;4. New message starts with normal English instead of Korean/Chinese.&lt;/p&gt;&lt;p&gt;Regards&lt;/p&gt;&lt;p&gt;&amp;nbsp;&lt;/p&gt;&lt;p&gt;Basheer &lt;/p&gt;&lt;p&gt;&amp;nbsp;&lt;/p&gt;

Hello

I have looked through various threads on the displaying of Korean characters but have not found a solution to my problem. 
So here is what I struggle with:

I sent a message written in Korean to myself.
The characters appeared fine when I wrote them in both Subject field and text body.

When I received the message back all Korean characters were replaced with black-border squares in both Subject line and text body. Looking at the same message on a webmail interface shows the Korean characters just fine.

The character set on Options is "UTF-8", which I believe is what should work in most cases. The version of PegasusMail is 4.41 (32bit) on WindowsXP SP2.
Please see below for the message contents including redacted headers.

Any ideas what could resolve this ?
kaihora

---

Return-Path: <...>
Delivered-To: ...
Received: (qmail invoked by alias); 04 Dec 2012 14:59:20 -0000
Received: from unknown (EHLO [...]) [...]
by ... (mp034) with SMTP; 04 Dec 2012 15:59:20 +0100
X-Authenticated: #8897935
X-Provags-ID: V01U2FsdGVkX1+keb9mRzCkBT8xZDvo2AlSX6K5OAs8XDenNe/1GQ
hZZt50wmukuCVY
From: ...
To: ...,
...
Date: Tue, 04 Dec 2012 15:00:23 -0000
MIME-Version: 1.0
Subject: =?UTF-8?Q?=ED=95=9C=EA=B7=B9_sample?=
Reply-to: ...
BCC: (Suppressed)
Message-ID: <...>
X-Confirm-Reading-To: ...
X-pmrqc: 1
Return-receipt-to: ...
Priority: normal
X-mailer: Pegasus Mail for Windows (4.41)
Content-type: text/plain; charset=UTF-8
Content-transfer-encoding: Quoted-printable
Content-description: Mail message body
...
X-PMFLAGS: 34087104 0 1 PS7GHWX4.CNM


=EC=95=88=EB=85=95 =ED=95=98=EC=85=94=EC=9A=94.
=EB=A7=A4=EC=9D=BC =ED=95=9C=EA=B7=B9=EC=96=B4=EB=A5=BC =EB=B0=B0=EC=9A=B0=
=EC=96=B4=EC=9A=94.
=EC=9D=BC=EA=B3=B1 =EC=8B=9C =ED=9B=84=EC=97=90 =EB=8B=A8=EB=94=94 =EC=8B=9C=
=EB=82=B4=EC=97=90 =EA=B0=80=EC=9A=94.
=EC=9D=BC=EA=B3=B1 =EC=8B=9C =EB=B0=98 =ED=9B=84=EC=97=90 =ED=95=9C=EA=B7=B9=
=EC=96=B4 =ED=95=99=EC=83=9D=EC=9D=84 =EB=A7=8C=EB=82=98=EC=9A=94.
=EC=A3=BC=EB=A7=90=EC=97=90 =EC=BA=98=EB=8A=90=EA=B3=A0=EB=A6=AC=EB=AF=80=EC=
=97=90 =EB=93=B1=EC=82=B0=ED=95=98=EC=9A=94.
=EC=95=88=EB=85=95=ED=9E=88 =EA=B0=80=EC=84=B8=EC=9A=94.

---

&lt;p&gt;Hello&lt;/p&gt;&lt;p&gt;I have looked through various threads on the displaying of Korean characters but have not found a solution to my problem.&amp;nbsp; So here is what I struggle with: &lt;/p&gt;&lt;p&gt;I sent a message written in Korean to myself. The characters appeared fine when I wrote them in both Subject field and text body. &lt;/p&gt;&lt;p&gt;When I received the message back all Korean characters were replaced with black-border squares in both Subject line and text body. Looking at the same message on a webmail interface shows the Korean characters just fine.&lt;/p&gt;&lt;p&gt;The character set on Options is &quot;UTF-8&quot;, which I believe is what should work in most cases. The version of PegasusMail is 4.41 (32bit) on WindowsXP SP2. Please see below for the message contents including redacted headers. &lt;/p&gt;&lt;p&gt;Any ideas what could resolve this ? kaihora&lt;/p&gt;&lt;p&gt;---&lt;/p&gt;&lt;p&gt;Return-Path: &amp;lt;...&amp;gt; Delivered-To: ... Received: (qmail invoked by alias); 04 Dec 2012 14:59:20 -0000 Received: from unknown (EHLO [...]) [...] by ... (mp034) with SMTP; 04 Dec 2012 15:59:20 +0100 X-Authenticated: #8897935 X-Provags-ID: V01U2FsdGVkX1+keb9mRzCkBT8xZDvo2AlSX6K5OAs8XDenNe/1GQ hZZt50wmukuCVY From: ... To: ..., ... Date: Tue, 04 Dec 2012 15:00:23 -0000 MIME-Version: 1.0 Subject: =?UTF-8?Q?=ED=95=9C=EA=B7=B9_sample?= Reply-to: ... BCC: (Suppressed) Message-ID: &amp;lt;...&amp;gt; X-Confirm-Reading-To: ... X-pmrqc: 1 Return-receipt-to: ... Priority: normal X-mailer: Pegasus Mail for Windows (4.41) Content-type: text/plain; charset=UTF-8 Content-transfer-encoding: Quoted-printable Content-description: Mail message body ... X-PMFLAGS: 34087104 0 1 PS7GHWX4.CNM =EC=95=88=EB=85=95 =ED=95=98=EC=85=94=EC=9A=94. =EB=A7=A4=EC=9D=BC =ED=95=9C=EA=B7=B9=EC=96=B4=EB=A5=BC =EB=B0=B0=EC=9A=B0= =EC=96=B4=EC=9A=94. =EC=9D=BC=EA=B3=B1 =EC=8B=9C =ED=9B=84=EC=97=90 =EB=8B=A8=EB=94=94 =EC=8B=9C= =EB=82=B4=EC=97=90 =EA=B0=80=EC=9A=94. =EC=9D=BC=EA=B3=B1 =EC=8B=9C =EB=B0=98 =ED=9B=84=EC=97=90 =ED=95=9C=EA=B7=B9= =EC=96=B4 =ED=95=99=EC=83=9D=EC=9D=84 =EB=A7=8C=EB=82=98=EC=9A=94. =EC=A3=BC=EB=A7=90=EC=97=90 =EC=BA=98=EB=8A=90=EA=B3=A0=EB=A6=AC=EB=AF=80=EC= =97=90 =EB=93=B1=EC=82=B0=ED=95=98=EC=9A=94. =EC=95=88=EB=85=95=ED=9E=88 =EA=B0=80=EC=84=B8=EC=9A=94. &lt;/p&gt;&lt;p&gt;--- &lt;/p&gt;
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft